Gazebo_ros module missing

asked 2016-11-29 18:28:31 -0500

sirsomething gravatar image

So basically I'm trying to run a model on gazebo and since I'm very new to Ros and gazebo I have no idea why I'm having this problem.

SUMMARY
========

PARAMETERS
 * /robot_description: <?xml version="1....
 * /rosdistro: jade
 * /rosversion: 1.11.20
 * /use_sim_time: True

NODES
  /
    gazebo (gazebo_ros/gzserver)
    gazebo_gui (gazebo_ros/gzclient)
    mybot_spawn (gazebo_ros/spawn_model)

auto-starting new master
process[master]: started with pid [28640]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 7f71e714-b692-11e6-a90c-780cb87358de
process[rosout-1]: started with pid [28653]
started core service [/rosout]
process[gazebo-2]: started with pid [28657]
process[gazebo_gui-3]: started with pid [28672]
process[mybot_spawn-4]: started with pid [28684]
Traceback (most recent call last):
  File "/home/jorge/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/scripts/spawn_model", line 26, in <module>
    from gazebo_ros import gazebo_interface
ImportError: No module named gazebo_ros
[ INFO] [1480465101.233185195]: Finished loading Gazebo ROS API Plugin.
[ INFO] [1480465101.233776206]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
[mybot_spawn-4] process has died [pid 28684, exit code 1, cmd /home/jorge/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/scripts/spawn_model -urdf -param robot_description -model mybot __name:=mybot_spawn __log:=/home/jorge/.ros/log/7f71e714-b692-11e6-a90c-780cb87358de/mybot_spawn-4.log].
log file: /home/jorge/.ros/log/7f71e714-b692-11e6-a90c-780cb87358de/mybot_spawn-4*.log
[ INFO] [1480465102.030520375, 0.023000000]: waitForService: Service [/gazebo/set_physics_properties] is now available.
[ INFO] [1480465102.084461066, 0.074000000]: Physics dynamic reconfigure ready.

When I run

roslaunch mybot_gazebo mybot_world.launch

It will give me the problem above: ImportError: no module named gazebo_ros

I'm running ubuntu 14.04 and ros-jade

Thanks for the help and ask anything if i've not provided all the info

edit retag flag offensive close merge delete

Comments

You closed the question with right answer was accepted, but I don't see any answer.

If you've solved your own question in the meantime, please post the solution as an answer, and accept your own answer by ticking the checkmark to the left of the answer.

gvdhoorn gravatar imagegvdhoorn ( 2016-11-30 05:21:59 -0500 )edit