Ask Your Question
0

rtabmap ignore odometry

asked 2016-11-22 08:19:55 -0500

gijsje170 gravatar image

Can i set rtabmap_ros to ignore the odometry of the robot? At this moment the odometry of the robot is not good enough and will start to conflict with rtabmap resulting in a robot not knowing its position.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-11-24 13:58:02 -0500

matlabbe gravatar image

Hi,

rtabmap_ros requires odometry to work. The odometry can come from the robot (wheel odometry) or any other sources like visual odometry. rtabmap_ros has a rgbd_odometry node that can be used to generate visual odometry for convenience. You will have to disable odometry from your robot (at least the TF) if you use another source of odometry.

cheers

edit flag offensive delete link more

Comments

Hi! I'm trying to use rgbd_odometry instead of wheel odom. Do you have any suggestions on how to disable odom from robot in TF? I also posted a question here.

Dox gravatar image Dox  ( 2018-08-01 06:19:42 -0500 )edit
1

you may comment this line: https://github.com/amor-ros-pkg/rosar...

matlabbe gravatar image matlabbe  ( 2018-08-01 13:20:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-11-22 08:19:55 -0500

Seen: 464 times

Last updated: Nov 24 '16