Error when using rqt_graph.

asked 2016-10-21 04:02:51 -0500

BalakrishnanR1992 gravatar image

updated 2016-10-21 04:24:31 -0500

gvdhoorn gravatar image

Whenever I run the rqt_graph command the following error appears in my terminal:

RecursivePluginProvider.discover() loading plugin "qt_gui_cpp/CppPluginProvider" failed:
Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui/recursive_plugin_provider.py", line 57, in discover
    instance = self._plugin_provider.load(plugin_descriptor.plugin_id(), None)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/rqt_gui/ros_plugin_provider.py", line 92, in load
    return class_ref()
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui_cpp/cpp_plugin_provider.py", line 43, in __init__
    RosPluginlibPluginProvider(qt_gui_cpp.RosPluginlibPluginProvider_ForPlugins('qt_gui', 'qt_gui_cpp::Plugin')),
TypeError: RosPluginlibPluginProvider_ForPlugins(): argument 1 has unexpected type 'str'

However the window does pop up with all the nodes and topics listed. Do I need to worry about this, if so, what is the fix ??

I tried looking for fixes online and have already tried:

sudo apt-get install ros-kinetic-rqt ros-kinetic-rqt-common-plugins

again

tried to reinstall qt_gui_core as the qt_gui_cpp seems to be a part of the qt_gui_core. But the install doesnt happen as qt_gui_core is not found.

Thanks in advance, A noob

edit retag flag offensive close merge delete

Comments

Please use the Preformatted Text button next time when copy/pasting console output into your question. It's the one with 101010 on it. Thanks.

gvdhoorn gravatar imagegvdhoorn ( 2016-10-21 04:24:56 -0500 )edit

Duly noted. Thanks :)

BalakrishnanR1992 gravatar imageBalakrishnanR1992 ( 2016-10-23 23:22:16 -0500 )edit

Have you solved the probelm? I have the same.

Cabbage gravatar imageCabbage ( 2017-10-07 01:52:32 -0500 )edit

I also have the same problem, does anyone? know a solution?

1ros100 gravatar image1ros100 ( 2019-06-25 01:20:12 -0500 )edit