Ask Your Question
0

rqt package segmentaion fault

asked 2020-05-14 09:03:15 -0500

Timbotic gravatar image

updated 2020-05-15 02:27:40 -0500

Hey,

when I am trying to run any node from the rqt package I am getting a segmentation fault:

[15:54:27]~:

rosrun rqt_gui rqt_gui

Segmentation fault (core dumped)

[15:54:49]~:

rosrun rqt_graph rqt_graph

Segmentation fault (core dumped)

I am running ros kinetic on ubuntu 16.04

Thank you in advance for your help!

One Solution I found, for future reference: I was able to call these functions by just calling

rqt

or

rqt_graph

edit retag flag offensive close merge delete

Comments

Do you have a non-default version of Qt / sip installed?

Dirk Thomas gravatar image Dirk Thomas  ( 2020-05-14 13:09:56 -0500 )edit

No and thank you for trying to help, I actually was able to circumvent the problem by just calling

rqt_graph

which worked for me.

Timbotic gravatar image Timbotic  ( 2020-05-15 02:25:35 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-05-15 03:50:50 -0500

Timbotic gravatar image

Okay now I found the real problem! There seemed to be some python version issue. I also had anaconda installed, which I deleted since I dont need it anymore and reinstalled python and ros-kinetic, which solved the problem.

This also seems to be the reason for getting an error when trying to call

rospack depends1 [Packagename]

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-05-14 09:03:15 -0500

Seen: 76 times

Last updated: May 15 '20