ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Run move_base.launch error:[move_base-4] process has died [pid 3825, exit code -11......

asked 2016-10-20 09:52:54 -0500

FrankYou gravatar image

hello everyone!

I got a problem when i run move_base.launch to realize Navigation. The error info in terminal is:

[move_base-4] process has died [pid 3825, exit code -11, cmd /opt/ros/indigo/lib/move_base/move_base __name:=move_base __log:=/home/youjian/.ros/log/b66363a2-96cf-11e6-9e46-e4f89cf5c788/move_base-4.log].
log file: /home/youjian/.ros/log/b66363a2-96cf-11e6-9e46-e4f89cf5c788/move_base-4*.log

i didnt find move_base-4.log, however i find the error info in master.log, the error info is:

[rosmaster.threadpool][**ERROR**] 2016-10-20 22:16:04,075: Traceback (most recent call last):
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rosmaster/", line 218, in run
    result = cmd(*args)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rosmaster/", line 208, in publisher_update_task
    xmlrpcapi(api).publisherUpdate('/master', topic, pub_uris)
  File "/usr/lib/python2.7/", line 1233, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.7/", line 1587, in __request
  File "/usr/lib/python2.7/", line 1273, in request
    return self.single_request(host, handler, request_body, verbose)
  File "/usr/lib/python2.7/", line 1301, in single_request
    self.send_content(h, request_body)
  File "/usr/lib/python2.7/", line 1448, in send_content
  File "/usr/lib/python2.7/", line 975, in endheaders
  File "/usr/lib/python2.7/", line 835, in _send_output
  File "/usr/lib/python2.7/", line 797, in send
  File "/usr/lib/python2.7/", line 778, in connect
    self.timeout, self.source_address)
  File "/usr/lib/python2.7/", line 571, in create_connection
    raise err
**error**: [Errno 111] Connection refused

actually, i managed to run move_base.launch before, but the robot was navigated weirdly, so i want to make the move_base node print the cmd_vel info. Since i cant find move_base.cpp in /opt/ros/indigo, i copied the move_base package from Github and modified the package, then catkin_make it in catkin_ws. However, i didnt make it. So i deleted all files related to move_base in catkin_ws, the result is i couldnt run move_base.launch any more and constantly report the error above.

i have tried reinstall ros-indigo-move-base, but it didnt work. Could anyone give me some help or suggestions? Do i need to reinstall the ROS?>...<

thanks in advance!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2016-10-21 02:23:23 -0500

FrankYou gravatar image

i find no other ways, so i finally reinstall my ROS and delete the original catkin_ws folder, and recreate my_robot package, after that it works

edit flag offensive delete link more

answered 2016-10-20 10:12:07 -0500

huanxiner gravatar image

Could there be any leftover move_base package files in build/devel/install folder of your catkin_ws? If so, find them and delete them.

edit flag offensive delete link more


thank you for your reply. but there is no install folder in /devel dir, maybe your ros version is different from mine...

FrankYou gravatar image FrankYou  ( 2016-10-20 19:44:03 -0500 )edit

Question Tools

1 follower


Asked: 2016-10-20 09:52:54 -0500

Seen: 5,073 times

Last updated: Oct 21 '16