Ask Your Question
0

Kinetic install not setting ROS_ environment variables

asked 2016-10-02 19:39:57 -0500

rcrowe gravatar image

I've followed the instructions to install Kinetic on Ubuntu 16.04, and there were no errors during the install, but the setup scripts aren't setting up the ROS_ environment variables. (ROS_ROOT, ROS_PACKAGE_PATH). My setup scripts are in /opt/ros/kinetic. setup.bash just runs setup.sh, but looking at setup.sh, it doesn't seem to be setting or exporting any ROS_ variables. There are no errors generated, including nothing about problems with the temp file. It also looks like it runs _setup_util.py, but I see no mention of any ROS_ environment variables in that file either. The CATKIN_ variables aren't getting set either, but I have catkin installed. I haven't set up any workspaces yet, since I'm trying to get the install right.

It seems like the environment isn't right, but looking at the scripts I don't see any place where the ROS_ variables should be set, so I'm wondering if the docs might be out of sync with Kinetic. If the docs are correct, could anyone point me in the right direction to fix this?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-10-03 12:47:06 -0500

rcrowe gravatar image

updated 2016-10-03 13:15:49 -0500

gvdhoorn gravatar image

Found it. Yes, I was sourcing the scripts, but I had aliases that were causing problems with the scripts. Once I moved the line in ~/.bashrc above where I set my aliases, things worked correctly.

It would be good if future versions of the scripts used the "command" syntax to avoid conflicts with aliases. For example:

% command ls -l

instead of just:

% ls -l
edit flag offensive delete link more

Comments

I can't find which component is actually responsible for generating the various setup files, but I imagine reporting what you observed and found out would be a valuable bug report. If you would consider reporting it, that'd be very much appreciated.

gvdhoorn gravatar image gvdhoorn  ( 2016-10-03 13:13:48 -0500 )edit

Also (and a bit pedantic): in general it's better to update your original question with any new or additional information you might have, instead of posting an answers yourself. In this case it's ok, as you're basically actually answering your own question, but please keep it in mind in the future.

gvdhoorn gravatar image gvdhoorn  ( 2016-10-03 13:15:35 -0500 )edit

I'd be happy to report it and suggest the fix, but I can't seem to find which organization and repo to report it in. I've searched for setup.sh and install, but nothing comes up. Any ideas?

rcrowe gravatar image rcrowe  ( 2016-10-03 14:17:01 -0500 )edit

If I'm not mistaken, Catkin generates those files (here fi). The correct tracker would then be ros/catkin/issues.

gvdhoorn gravatar image gvdhoorn  ( 2016-10-03 14:25:04 -0500 )edit

Thanks, I've submitted the issue:

https://github.com/ros/catkin/issues/829

rcrowe gravatar image rcrowe  ( 2016-10-03 15:34:03 -0500 )edit

Thanks. From the description/comments on that issue I see you have a rather uncommon alias configured: .='ls -aF'. That would certainly make things not work. For now I guess you'll have to use source, instead of .. I can also understand the hesitation of @Dirk Thomas.

gvdhoorn gravatar image gvdhoorn  ( 2016-10-04 01:48:14 -0500 )edit
0

answered 2016-10-03 02:00:19 -0500

gvdhoorn gravatar image

The documentation should be fine.

Are you running the setup.(ba)shscripts, or sourcing them?

Running won't work, as that will set the environment variables in a new (ba)sh session, then exit that session, leaving your original session untouched.

Make sure you source /opt/ros/kinetic/setup.bash.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-10-02 19:39:57 -0500

Seen: 279 times

Last updated: Oct 03 '16