Ask Your Question
0

ROS_comm Instal on Raspberry Pi 3 possibly stuck?

asked 2016-09-27 14:20:00 -0500

TacoCat_taCocaT gravatar image

updated 2016-09-27 16:15:47 -0500

I am a new user, so my apologies ahead of time for the noob question. I am currently installing ROS Indigo (ROS_comm) on my Raspberry Pi which has Raspbian (Jessie). The last command I ran was:

$ sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/indigo -j2

as per this set of instructions (step 3.3) Installing ROS Indigo on the Raspberry Pi

The terminal displays (typed by hand as mouse/keyboard unresponsive): /opt/ros/indigo/include/ros/serialization.h:223.5: note: in in expansion of macro 'ROS_CREATE_SIMPLE_SERIALIZER_ARM' ROS_CREATE_SIMPLE_SERIALIZER_ARM(double);

It has been stuck here for about 4 hours, not sure if this is normal or not. I can't seem to find any info on it. The mouse is hardly responding, so I take this as a bad sign. Any advice is gladly welcomed!

UPDATE: I killed the board and restarted. Ran the command again and it is stuck on the same spot. Green LED on pi is on (as opposed to iterating on/off).

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-10-31 10:56:01 -0500

vahidzj gravatar image

Have you tried increasing your swap? It is explained here: http://answers.ros.org/question/21957...

edit flag offensive delete link more
0

answered 2016-10-01 17:44:35 -0500

anonymous user

Anonymous

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-09-27 14:20:00 -0500

Seen: 480 times

Last updated: Oct 01 '16