Ask Your Question
0

Raspberry Pi crashes when I try to build the Catkin workspace

asked 2016-12-07 03:45:00 -0500

sharan100 gravatar image

Currently I am trying to follow this guide here to start using the Robot Operating System (currently ROS Indigo). I am at the very final stage where I am trying to build the Catkin workspace using the command:

sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/indigo This command is from Section 3.3

It works perfectly fine for the first 50 packages or so, but starts hanging when it reaches rospack. I am currently using the Raspbian Jessie, with the x11 desktop environment and trying to install the Desktop GUI version of ROS. I have followed every instruction till this point and am a bit baffled as to my next step.

image description

Here's a picture of the terminal up until when the raspberry pi freezes

Is there a way to change the command mentioned above so that I can ignore rospack completely and deal with the issue once the dependencies have been resolved (the objective of Section 3.3 of the guide)?

It can also be observed that the Raspberry Pi hits 100% processing and the screen blacks out after a little bit. The clock skew warning comes up on every package. I am not sure if this has something to do with this crash.

Please ask me if you would like to get a picture of higher defintion for the terminal up until the freeze and crash


UPDATE

Here is a picture of what happens after a little while when I try and move the mouse :

image description

I'm going to try and run this on a different terminal altogether. The current terminal is a Yakuake (Guake).


UPDATE 2

As I suspected, it has nothing to do with the terminal I am using. I have found this resource from this very question, to ignore the package rospack. I am going to try this out in a bit.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2016-12-07 04:13:19 -0500

updated 2016-12-07 04:27:52 -0500

The freezes I encounter are usually either due to disk i/o (especially memory swapping) or hardware drivers. I guess the latter can be excluded, so you should monitor the memory exhaustion (e.g. use watch -n 0.5 free -m). You may try to disable swap (sudo swapoff -a), so the compilation is just killed when the physical memory is full.

Edit:

I am not sure whether catkin_make_isolated automatically parallelizes. If so, you might want to disable that (maybe append "-j1"?).

If it is the memory problem and disabling parallelization doesn't help, try to lower the complexity of the compilation of the problematic files.

  • compile without -g flag (in CMake, set the CMAKE_BUILD_TYPE to Release)
  • reduce optimization (this will make it slower) by explicitly using -Og or even -O0

Otherwise, getting more RAM is usually an option.

The above are just ideas from the top of my head. Make sure it is the memory swapping problem first. Also: Have you tried waiting?

edit flag offensive delete link more

Comments

But I don't want the compilation killed, rospack is certainly very important and I would like to know how to actually build it in my catkin workspace.

sharan100 gravatar imagesharan100 ( 2016-12-07 04:15:26 -0500 )edit

I'll try appending the -j1 option and seeing what happens. Let me get back to you in a few minutes.

sharan100 gravatar imagesharan100 ( 2016-12-07 04:24:40 -0500 )edit
1

-j1 option seems to be working, but I am facing other errors. I guess, that's a topic for another question!

sharan100 gravatar imagesharan100 ( 2016-12-07 04:48:17 -0500 )edit

-j1 did the trick. Thanks ! I have covered the setup as a writeup here :

https://hareshmiriyala.wordpress.com/...

Haresh Karnan gravatar imageHaresh Karnan ( 2018-02-26 18:56:00 -0500 )edit

-j1 did the trick

suab123 gravatar imagesuab123 ( 2019-08-13 07:06:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-12-07 03:45:00 -0500

Seen: 4,415 times

Last updated: Dec 07 '16