Ask Your Question
0

catkin build fail.

asked 2014-11-13 06:01:39 -0500

ASHISH CHHONKAR gravatar image

updated 2014-11-13 09:00:17 -0500

bvbdort gravatar image

sir I tried to build the package which is created at desktop workspace. i follow the following commands

1) mkdir -p /home/chhonkar/Desktop/imagews/src

2) cd /home/chhonkar/Desktop/imagews/src/

3) catkin_create_pkg pack1 roscpp std_msgs rospy

4) cd .. (reached to /home/chhonkar/Desktop/imagews)

5) catkin_make

But this create problem. build process is not successful. i got some error. here i am copy few part of error.

RuntimeError: Multiple packages found with the same name "ardrone_autonomy":
- ardrone_autonomy
- share/ardrone_autonomy
CMake Error at /opt/ros/indigo/share/catkin/cmake/safe_execute_process.cmake:11 (message):

  execute_process(/home/chhonkar/Desktop/imageproc/build/catkin_generated/env_cached.sh
  "/usr/bin/python" "/usr/bin/empy" "--raw-errors" "-F"
  "/home/chhonkar/Desktop/imageproc/build/catkin_generated/order_packages.py"
  "-o"
  "/home/chhonkar/Desktop/imageproc/build/catkin_generated/order_packages.cmake"
  "/opt/ros/indigo/share/catkin/cmake/em/order_packages.cmake.em") returned
  error code 1
Call Stack (most recent call first):
  /opt/ros/indigo/share/catkin/cmake/em_expand.cmake:25 (safe_execute_process)
  /opt/ros/indigo/share/catkin/cmake/catkin_workspace.cmake:29 (em_expand)
  CMakeLists.txt:63 (catkin_workspace)
-- Configuring incomplete, errors occurred!
See also "/home/chhonkar/Desktop/imageproc/build/CMakeFiles/CMakeOutput.log".
See also "/home/chhonkar/Desktop/imageproc/build/CMakeFiles/CMakeError.log".
edit retag flag offensive close merge delete

Comments

2

Did you create workspace before creating package ?

bvbdort gravatar image bvbdort  ( 2014-11-13 09:04:02 -0500 )edit

The error message indicates that you have multiple packages with the same name in your source space. Can you please post the recursive content under your workspace folder: /home/chhonkar/Desktop/imagews/src

Dirk Thomas gravatar image Dirk Thomas  ( 2014-11-13 12:20:58 -0500 )edit

@bvbdort yes i created the workspace of name imagews......

ASHISH CHHONKAR gravatar image ASHISH CHHONKAR  ( 2014-11-13 14:56:37 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-11-13 19:24:29 -0500

The problem is that you have two copies of the package ardrone_autonomy in your system. Remove one of them.

If you don't need that package you can do:

sudo apt-get remove ros-indigo-ardrone-autonomy

Then try to run catkin_make again.

edit flag offensive delete link more

Comments

whenever i open a new terminal following bash come in start... is this affect the system, because previously it not come.


bash: source/home/chhonkar/Desktop/imagews/devel/setup.bash: No such file or directory chhonkar@chhonkar-pc:~$


ASHISH CHHONKAR gravatar image ASHISH CHHONKAR  ( 2014-11-14 04:15:43 -0500 )edit

You will probably need to rebuild the workspace in /home/chhonkar/Desktop/imagews

Martin Peris gravatar image Martin Peris  ( 2014-11-16 19:22:45 -0500 )edit

@Martin thanks for your response..... i resolved the problem. above problem of bash has been solved my removing all paths from bashrc file except opt/ros/indigo....

ASHISH CHHONKAR gravatar image ASHISH CHHONKAR  ( 2014-11-17 10:06:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-13 06:01:39 -0500

Seen: 3,023 times

Last updated: Nov 13 '14