Ask Your Question
0

ROS-Indigo installation on Raspberry-Pi failes on "rosmake" package

asked 2016-10-26 10:46:30 -0600

bogo gravatar image

Hello ROS community,

I'm installing ROS on a Raspberry-Pi 2, I've followed this guide closely to install ROS on Jessie.

On Section 3.3 - "Building the catkin workspace":
Running the first command - "Invoke catkin_make_isolated":

sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/indigo

The building process begins installing the packages (48 of them), but on package 21 - which is the 'rosmake' package, it fails, providing the following error message:

==> Processing catkin package: 'rosmake'
==> Building with env: '/opt/ros/indigo/env.sh'
Makefile exists, skipping explicit cmake invocation...
==> make cmake_check_build_system in '/home/pi/ros_catkin_ws/build_isolated/rosmake'
make: * No rule to make target 'cmake_check_build_system'. Stop.
<== Failed to process package 'rosmake':
Command '['/opt/ros/indigo/env.sh', 'make', 'cmake_check_build_system']' returned non-zero exit status 2

Reproduce this error by running: ==> cd /home/pi/ros_catkin_ws/build_isolated/rosmake && /opt/ros/indigo/env.sh make cmake_check_build_system

Command failed, exiting.

I've tried building with the -j2 option, just in case, although most likely it's not related to my problem.

What can I do about it ? There don't seem to be any records of this problem on any forums etc., from what I've seen through a quick search..

Thanks in advance for any suggestions and feedback.

edit retag flag offensive close merge delete

Comments

same problem here but with ROSPACK..... any help will be appreciate

fgastald gravatar imagefgastald ( 2017-01-03 01:43:57 -0600 )edit

Did you ever find the solution because I am currently struggling with Rospack aswell

Toasted_Tiger gravatar imageToasted_Tiger ( 2017-08-27 15:50:16 -0600 )edit

@Toasted_Tiger Unfortunately no. Eventually I didn't use ROS at all for what I was doing, so had no need to fix the problem.. However, William's suggestion seems worth trying, although IIRC it fixed my specific issue but the installation got stuck on a later stage... Good luck !

bogo gravatar imagebogo ( 2017-08-30 00:16:48 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-01-03 13:08:42 -0600

William gravatar image

It looks like your generated Makefile is messed up. Use --force-cmake or remove the build folder for the package that's not building (in this case build_isolated/rosmake) and try again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-10-26 10:46:30 -0600

Seen: 575 times

Last updated: Jan 03 '17