ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

How to use script from ur_modern_driver

asked 2016-09-14 15:58:50 -0500

Pawel gravatar image

updated 2016-09-15 07:20:44 -0500

gvdhoorn gravatar image


I am currently running on Ubuntu 14.04.5 LTS, UR Software, and am running Indigo. I am able to get roslaunch to work, however when I try to run rosrun ur_modern_driver I get the error

rospkg.common.ResourceNotFound: ur_driver

I have run the rosrun command in a new terminal after running source ~/catkin_ws/devel/setup.bash

Any thoughts or insights are greatly appreciated!



edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-09-15 07:26:10 -0500

gvdhoorn gravatar image

updated 2016-09-15 08:39:24 -0500

The script from ur_modern_driver includes a (as far as I can tell) erronous roslib.load_manifest(..) line (here), that references the ur_driver package.

Quick work-around: make sure to have the ur_driver package available on your PC: either install ros-$distro-ur-driver, or clone the universal_robot git repository into your catkin workspace (don't forget to rebuild the workspace).

Now rosrun ur_modern_driver should work.

You could also just remove the roslib.load_manifest(..) line: it is no longer needed.

PS: it would be nice if you could report this to the ur_modern_driver issue tracker.

edit flag offensive delete link more


Even if in ur_modern_driver is fixed, having the ROS-I universal_robot packages installed seems like a good idea in order to do almost anything useful (e.g. to have the URDF in ur_description).

Miguel Prada gravatar image Miguel Prada  ( 2016-09-15 07:42:03 -0500 )edit

Yes, good point. Although that depends on what you actually want to do, of course.

gvdhoorn gravatar image gvdhoorn  ( 2016-09-15 08:36:38 -0500 )edit

Indeed, that's where the almost comes from ;)

Miguel Prada gravatar image Miguel Prada  ( 2016-09-16 02:34:38 -0500 )edit

I had the same error: "rospkg.common.ResourceNotFound: ur_driver" and I solved it by: sudo apt-get install ros-kinetic-ur-driver

BigHopes gravatar image BigHopes  ( 2020-02-04 00:13:19 -0500 )edit

please anyone help me i am always getting "Waiting for server..." i want to move the ur in gazebo by their joint state cordinates

nullspace gravatar image nullspace  ( 2020-11-02 03:00:44 -0500 )edit

Question Tools

1 follower


Asked: 2016-09-14 15:58:50 -0500

Seen: 926 times

Last updated: Sep 15 '16