ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

[rospack] Error: package 'turtlebot_gazebo' not found

asked 2016-09-08 20:47:44 -0500

alienmon gravatar image

updated 2016-09-09 02:19:09 -0500

Yesterday my turtlebot_gazebo worked just fine.Suddenly today everytime I open a new terminal, the following error immediately appears (BEFORE I DO ANYTHING):

[rospack] Error: package 'turtlebot_gazebo' not found
[rospack] Error: package 'turtlebot_gazebo' not found
[rospack] Error: package 'turtlebot_navigation' not found

When I navigate to /opt/ros/indigo/share , all the turtlebotpackages disappear. SO I follow the instruction here

sudo apt-get install ros-indigo-turtlebot ros-indigo-turtlebot-apps ros-indigo-turtlebot-interactions ros-indigo-turtlebot-simulator ros-indigo-kobuki-ftdi ros-indigo-rocon-remocon ros-indigo-rocon-qt-library ros-indigo-ar-track-alvar-msgs

and I also install the turtlebot_gazebo

When I install the turtlebot_gazebo, it shows

ros-indigo-turtlebot-gazebo is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded.

HOWEVER the same problem still appears, and the turtlebot_gazebo package is not in my directory.



I uninstall and reinstall turtlebot.. now turtlebot_gazebo is available, but when i try to launch the example.

 File "/usr/lib/python2.7/dist-packages/rospkg/", line 200, in get_path
    raise ResourceNotFound(name, ros_paths=self._ros_paths)
rospkg.common.ResourceNotFound: kobuki_description
ROS path [0]=/opt/ros/indigo/share/ros
ROS path [1]=/opt/ros/indigo/share
ROS path [2]=/opt/ros/indigo/stacks
while processing /opt/ros/indigo/share/turtlebot_gazebo/launch/includes/kobuki.launch.xml:
Invalid <param> tag: Cannot load command parameter [robot_description]: command [/opt/ros/indigo/share/xacro/ '/opt/ros/indigo/share/turtlebot_description/robots/kobuki_hexagons_asus_xtion_pro.urdf.xacro'] returned with code [1]. 

Param xml is <param command="$(arg urdf_file)" name="robot_description"/>
The traceback for the exception was written to the log file

HELP I saw a lot of ppl facing the same problem. I tried the suggested solution, but It doesn't work for me.

edit retag flag offensive close merge delete


alienmon gravatar image alienmon  ( 2016-09-08 21:22:57 -0500 )edit

it's similar with this

alienmon gravatar image alienmon  ( 2016-09-09 00:48:11 -0500 )edit

Please respect the fact that forum contributors respond on their own time; we're not obligated to help you in any way.

ahendrix gravatar image ahendrix  ( 2016-09-09 21:08:21 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted

answered 2016-09-09 02:20:35 -0500

alienmon gravatar image

updated 2016-09-09 02:40:19 -0500

For the initial problem.

Uninstall and reinstalling turtlebot solve the problem.

sudo apt-get remove turtlebot-*
sudo apt-get intsall ros-indigo-turtlebot

For the later problem, I think I'll post it as a new question HERE

edit flag offensive delete link more

answered 2020-10-01 02:56:53 -0500

omkar_a_k gravatar image

After a lot of debugging, I realised this error was due to sourcing my catkin_ws (I had used the packages directly in catkin_ws rather than installing). Basically, I was getting this error at the start of the terminal because my .bashrc had export of my catkin_ws setup. So, I localised the issue to my catkin_ws. After exploring the filesystem of my catkin_ws, I found some .sh files under the directory catkin_ws/devel/etc/catkin/profile.d/ which belonged to turtlebot. Deleting those specific files solved my problem.

edit flag offensive delete link more



It solved my problem

Jesusloveyou gravatar image Jesusloveyou  ( 2021-05-10 09:29:51 -0500 )edit

Thank you. This solved my problem as well.

elena_a gravatar image elena_a  ( 2021-07-13 05:05:47 -0500 )edit

answered 2016-09-08 21:05:42 -0500

Shay gravatar image

It's probably because of your terminal environment. You need to do this in your new terminal:

source /opt/ros/indigo/setup.bash
source ~/catkin_ws/devel/setup.bash
edit flag offensive delete link more


Nope. it's not the problem.source /opt/ros/indigo/setup.bash is alr in my bashrc. And source ~/catkin_ws/devel/setup.bash is not related w my problem

alienmon gravatar image alienmon  ( 2016-09-08 21:09:51 -0500 )edit

answered 2016-09-08 22:43:40 -0500

updated 2016-09-09 00:16:45 -0500

ROS has some kind of a problem. Every time you open up your terminal, after entering into your catkin work space, you need to run this source ~/catkin_ws/devel/setup.bash. So, here is a thing you need to do.

cd ~/catkin_ws
source ~/catkin_ws/devel/setup.bash

Let me know what appears after that.

Edit 1: September 09. OK. Then, I feel that your problem is related to some setting. Sometimes, accidentally something happens and then things stop working in ROS. In this case, what I do is uninstall ROS and install again and check if the error persist. If you want to try, sometimes it is good otherwise wait for someone else to response.

To remove ROS, you need to run this

 sudo apt-get remove ros-*

Best of luck.

edit flag offensive delete link more



As I mentioned in my comment above. I beleive that It has NOTHING to do with that. Cause the error appears even before I tried to do anything. Just immediately after I open a new terminal

alienmon gravatar image alienmon  ( 2016-09-08 23:30:22 -0500 )edit

Moreover , turtlebot_gazebo is a package that I installed, Not a package that I created on my own.... so it's supposed to go to /opt/ros/indigo/share

alienmon gravatar image alienmon  ( 2016-09-08 23:31:21 -0500 )edit

Hi Thanks for your suggestion. I reinstalled turtlebot instead of the whole ROS. The error message doesn't appear again in my terminal. However I can not launch thedemo, please see my quest I edited it

alienmon gravatar image alienmon  ( 2016-09-09 00:43:24 -0500 )edit

@alienmon bro can you please post the step that helped you to disappear the error message ? because I have the same problem. I am using ROS kinetic. Thanks in advance

Ibrahim_aerospace gravatar image Ibrahim_aerospace  ( 2018-10-30 09:16:12 -0500 )edit

answered 2021-03-20 12:48:42 -0500

askkvn gravatar image

updated 2021-03-20 12:50:22 -0500

Clone turtle_simulator Github package and put it inside your src directory.

edit flag offensive delete link more

Question Tools



Asked: 2016-09-08 20:47:44 -0500

Seen: 12,872 times

Last updated: Mar 20 '21