How can I use the teleoperation with iRobot Roomba 645 and ROS Indigo?

asked 2016-09-04 19:18:10 -0500

Diana_Elyza gravatar image

updated 2016-09-22 12:09:06 -0500

Hi!!!

I'm new in ROS and I want to build a TurtleBot using iRobot 645 and Kinect with ROS Indigo. I've followed the tutorial http://wiki.ros.org/turtlebot_bringup... to do the teleoperation to begin, I've changed the hardware parameters but I get the next error:

Failed to contact device with error: [Error reading from SCI port. No data.] Please check that the Create is powered on and the connector is plugged into Create

The robot is power on, and the UST-TTL is working because I've used it to move the robot via serial communication using the iRobot Create 2 Open Interface (OI) Specification based on the iRobot Roomba 600 commands. Also I've tried to use this: https://github.com/AutonomyLab/create... without results.

I'd thank you a lot if you could help me.

Greetings!!!

More Information:

I've trying to connect ROS with this robot executing the next commands:

 export TURTLEBOT_BASE=create
 export TURTLEBOT_STACKS=circles
 export TURTLEBOT_SERIAL_PORT=/dev/ttyUSB0
 roslaunch turtlebot_bringup minimal.launch

Then it appears the error. By that I tried the create_autonomy driver. I followed the instructions to install it and when I try to execute it with this commands:

 source ~/create_ws/devel/setup.bash
 roslaunch ca_driver create_2.launch [desc:=true] [publish_tf:=true]

The next message appears:

[create_2.launch] is neither a launch file in package [ca_driver] nor is [ca_driver] a launch file name
The traceback for the exception was written to the log file.

I've using a PL2303 USB to Serial Converter and an Adafruit FTDI Serial TTL-232 USB Cable. I've tried with a baud rate of 19200 and 115200 and nothing. I want to create a map (SLAM) with this robot using ROS. I'm very new in this and I'd thank you a lot if you could tell me step by step how can I do it.

Thanks and greetings!!!

edit retag flag offensive close merge delete

Comments

What were the specific issues with create_autonomy?

jacobperron gravatar image jacobperron  ( 2016-09-18 17:50:08 -0500 )edit
  1. The command source ~/create_ws/devel/setup.bash assumes that you have created the workspace in your home directory.

  2. Try roslaunch ca_driver create_2.launch (the square brackets signify optional parameters and should not be there literally, eg, desc:=true not [desc:=true])

jacobperron gravatar image jacobperron  ( 2016-09-21 16:39:25 -0500 )edit

Thank you by your answer Jacob!!!

  1. Yes, the workspace was created in my home directory.
  2. I tried your suggestion but the same error appears:

    [create2.launch] is neither a launch file in package [ca_driver] nor is [ca_driver] a launch file name

Diana_Elyza gravatar image Diana_Elyza  ( 2016-09-22 12:06:56 -0500 )edit
1

That error means that you have either not properly sourced the workspace where you built the driver, or the driver was never successfully built. I would go through all the steps in create_autonomy again and make sure you get no errors or suspicious warnings throughout the process.

jacobperron gravatar image jacobperron  ( 2016-09-22 14:49:14 -0500 )edit

Thanks again!!!

You're right. I solved the problem with the next commands:

cd ~/create_ws/
source ~/create_ws/devel/setup.bash
catkin_make --source ~/create_ws/src/create_autonomy/

But now, I do not how to do SLAM using Gmapping (for example) with this driver and with a Kinect

Greets

Diana_Elyza gravatar image Diana_Elyza  ( 2016-09-25 19:39:53 -0500 )edit

I think turtlebot uses the package depthimage_to_laserscan to convert the Kinect data to a message consumable by gmapping. I would read about these packages and if you still have trouble open a new question.

jacobperron gravatar image jacobperron  ( 2016-09-26 11:34:35 -0500 )edit

Thank you!!!

I'll read them.

Greetings

Diana_Elyza gravatar image Diana_Elyza  ( 2016-09-29 16:39:22 -0500 )edit

Hello!!!

Excuse me Jacob, but I have some doubts about the create package:

  1. How do you obtain the odometry?
  2. How can I open the models of the ca_description carpet in Gazebo or in Rviz?

Thanks

Diana_Elyza gravatar image Diana_Elyza  ( 2016-10-01 21:43:32 -0500 )edit