Ask Your Question
0

Hi while i was installing rosserial library for arduino in ubuntu 16.04 using command "sudo apt-get install ros-indigo-rosserial-arduino" but its coming unable to locate package,how should i resolve it

asked 2016-08-20 03:27:32 -0500

rahul gravatar image

should i downgrade ubuntu version, why its unable to locate pakage?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-08-20 08:37:30 -0500

ghkraju gravatar image

Try this "sudo apt-get install ros-kinetic-rosserial-arduino" or "sudo apt-get install ros-jade-rosserial-arduino".(This might be helpful cuz Ubuntu 16.04 supports kinetic officially but you can also build the packages separately which is not recommended). (Download the source from git hub: https://github.com/ros-drivers/rosserial and copy it in your local catkin_ws and run catkin_make. Not a recommended solution but for a workaround.)

I have tried "sudo apt-get install ros-indigo-rosserial-arduino" in Ubuntu 14.04. It is working fine.

you can also change the rosdistro to ros-jade i guess.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-08-20 03:27:32 -0500

Seen: 231 times

Last updated: Aug 20 '16