Skip urdfdom error during OSX installation

asked 2016-08-17 10:37:18 -0500

Humoros gravatar image

Hi, I'm using Mac OSX Yosemite, still trying to install ROS Indigo, and I've decided to move on from my last error (for the reason I gave here. So now my error is that, during the $ ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release step, I get the error(s?)

 CMake Error at CMakeLists.txt:5 (find_package):
  By not providing "Findurdfdom_headers.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "urdfdom_headers", but CMake did not find one.

  Could not find a package configuration file provided by "urdfdom_headers"
  with any of the following names:


  Add the installation prefix of "urdfdom_headers" to CMAKE_PREFIX_PATH or
  set "urdfdom_headers_DIR" to a directory containing one of the above files.
  If "urdfdom_headers" provides a separate development package or SDK, be
  sure it has been installed.

-- Configuring incomplete, errors occurred!
See also "/Users/School/ros_catkin_ws/build_isolated/urdf_parser_plugin/CMakeFiles/CMakeOutput.log".
<== Failed to process package 'urdf_parser_plugin': 
  Command '['/Users/School/ros_catkin_ws/install_isolated/', 'cmake', '/Users/School/ros_catkin_ws/src/robot_model/urdf_parser_plugin', '-DCATKIN_DEVEL_PREFIX=/Users/School/ros_catkin_ws/devel_isolated/urdf_parser_plugin', '-DCMAKE_INSTALL_PREFIX=/Users/School/ros_catkin_ws/install_isolated', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']' returned non-zero exit status 1

Reproduce this error by running:
==> cd /Users/School/ros_catkin_ws/build_isolated/urdf_parser_plugin && /Users/School/ros_catkin_ws/install_isolated/ cmake /Users/School/ros_catkin_ws/src/robot_model/urdf_parser_plugin -DCATKIN_DEVEL_PREFIX=/Users/School/ros_catkin_ws/devel_isolated/urdf_parser_plugin -DCMAKE_INSTALL_PREFIX=/Users/School/ros_catkin_ws/install_isolated -DCMAKE_BUILD_TYPE=Release -G 'Unix Makefiles'

which I assume has to do with my ignoring my last issue. So, is there a way to make everything that has to do with urdfdom be ignored during this [and future] steps? Thanks.

edit retag flag offensive close merge delete


Just realized you're following the ROS wiki's instructions. Have you tried this? Many people, including myself, used that script to (very succesfully) install ROS on Mac OS X. Not sure if it will fix the urdfdom issue though.

spmaniato gravatar image spmaniato  ( 2016-08-17 11:02:52 -0500 )edit

Hmm, I did try to use that at first but I switched to the wiki because of some error I've now forgotten. I GUESS I could retry from scratch but I honestly don't know what I'm doing and what problems this will cause, since I don't know if I must/how to/if I want to clean up. So...I'll try it I guess?

Humoros gravatar image Humoros  ( 2016-08-17 11:44:28 -0500 )edit

It seems like it worked! It said that everything was installed successfully after I used the curl thing from github. But how do I know if it installed properly? I tried rosversion ros but it couldn't locate it... Sorry if I'm supposed to make another topic for this; I will if I can't solve it soon.

Humoros gravatar image Humoros  ( 2016-08-17 12:37:21 -0500 )edit

Try running roscore (Don't forget to source the installation directory, like the script asks you to.) Also, check the version like this: rosversion -d

spmaniato gravatar image spmaniato  ( 2016-08-18 10:53:33 -0500 )edit

roscoreworked from the start and I did source it, but rosversion ros just didn't work...Your way works, thanks for the tip!

Humoros gravatar image Humoros  ( 2016-08-18 12:17:06 -0500 )edit