Ask Your Question
0

rosinstall_generator fails on OS X Maverick [closed]

asked 2014-03-19 04:30:24 -0500

zobi gravatar image

updated 2014-03-19 07:45:36 -0500

demmeln gravatar image

Hi,

I have recently tried to install ROS hydro on OS X with HomeBrew but the rosinstall_generator fails with: (links looking like that , because had no enough karma to publish a link :))

rosinstall_generator desktop_full --rosdistro hydro --deps --wet-only --tar > hydro-desktop-full-wet.rosinstall Traceback (most recent call last):
File "/usr/local/bin/rosinstall_generator", line 117, in rc = main() File "/usr/local/bin/rosinstall_generator", line 105, in main tar=args.tar) File "/Library/Python/2.7/site-packages/rosinstall_generator/generator.py", line 189, in generate_rosinstall names, unknown_names = _classify_names(distro_name, names) File "/Library/Python/2.7/site-packages/rosinstall_generator/generator.py", line 84, in _classify_names wet_distro = get_wet_distro(distro_name) File "/Library/Python/2.7/site-packages/rosinstall_generator/generator.py", line 170, in get_wet_distro _wet_distro = _get_wet_distro(distro_name) File "/Library/Python/2.7/site-packages/rosinstall_generator/distro.py", line 45, in get_distro return get_cached_distribution(index, distro_name) File "/Library/Python/2.7/site-packages/rosdistro/__init__.py", line 134, in get_cached_distribution cache = get_distribution_cache(index, dist_name) File "/Library/Python/2.7/site-packages/rosdistro/__init__.py", line 160, in get_distribution_cache yaml_gz_str = load_url(url, skip_decode=True) File "/Library/Python/2.7/site-packages/rosdistro/loader.py", line 59, in load_url raise URLError(str(e) + ' (%s)' % url) urllib2.URLError: (http: // ros.org / rosdistro / hydro-cache . yaml . gz)>

The problem is that it can't resolve the url: http: // ros . org / rosdistro / hydro-cache.yaml.gz. I believe the rewrite rules are missing from the ros server, as http: // www . ros . org / rosdistro / hydro-cache.yaml.gz is reachable and http: // ros . org / rosdistro / hydro-cache.yaml.gz is not.

Any help would be appreciated,

Thanks, Csongor

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by zobi
close date 2014-03-19 08:33:38

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-03-19 07:54:14 -0500

demmeln gravatar image

I can not reproduce this problem, it works just fine on OS X over here. And the cache without www is also reachable. Maybe it was a temporary problem. You could also try pip install -U rosinstall_generator, but I don't see how that should make much of a difference if the URL reachability is indeed the issue. Please double check that the URL is not reachable for you: wget http://ros.org/rosdistro/hydro-cache.yaml.gz.

edit flag offensive delete link more

Comments

Thanks.That is right, now it works. Might have been a temporary issue.

zobi gravatar image zobi  ( 2014-03-19 08:33:06 -0500 )edit

Hello, I'm struggling with the same problem. To double check I tried "wget..." as suggested above, and I get a message "-bash: wget: command not found" [on Mac OS X Mavericks]

voladoddi gravatar image voladoddi  ( 2014-07-09 13:09:03 -0500 )edit

OSX doesn't have wget installed by default. You can use

curl
instead or install wget through homebrew:
brew install wget

ahendrix gravatar image ahendrix  ( 2014-07-09 14:10:36 -0500 )edit

@ahendrix thanks for your comment. I did directly paste it in the browser URL bar and I couldn't access it. however, i put a "www" between "http://" and "ros.", and I could download the cache. It seems to be impossible to do so using rosintall_generator for me. Any ideas about a workaround?

voladoddi gravatar image voladoddi  ( 2014-07-09 20:14:17 -0500 )edit

Well, it turns out that the URL was not accessible from a secure wi-fi space even with access to it. I tried again after getting home from work and it runs fine. Strange. Thank you nevertheless.

voladoddi gravatar image voladoddi  ( 2014-07-09 20:29:23 -0500 )edit

Are you certain you have the latest version of rosinstall_generator? I have version 0.1.9 on linux; the same version should work on OSX. You should be able to get your rosinstall_generator version with

python -c 'import rosinstall_generator; print rosinstall_generator.__version__'

ahendrix gravatar image ahendrix  ( 2014-07-09 20:30:34 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-03-19 04:30:24 -0500

Seen: 673 times

Last updated: Mar 19 '14