ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Rosbag record dropping and corrupting data

asked 2016-08-02 14:43:32 -0600

gautam2410 gravatar image

updated 2016-08-02 14:56:30 -0600


I'm trying to store selected topics being published from various sensors sources (velodyne, monocular camera, IMUs) in a large bag file. I'm able to record the bagfile without seeing any errors. However, when I play back the file, I'm seeing the following errors:

  1. Some of the frames of the Velodyne data are being dropped. I've tried recording multiple bagfiles but I see this behavior in all of them

  2. From the monocular camera, I'm just recording the camera/image_raw topic . However, after about a minute into the bagfile, the camera input image splits into 2 unequal part and one of the parts get displaced (as seen in the pictures below). I'm seeing this behavior in most of the bagfiles and the time of split is random.

Original Image:

image description

Corrupted Image

image description

A few details about my setup:

  1. I have tried recording files at 2 buffer sizes 1024 and 0 (infinity) and I see these problems in both cases
  2. I have tried recording bagfiles on and Odroid XU4 and a high-performance laptop but that did not help
  3. I'm running ROS indigo on Ubuntu 14.04

Rosbag info:

image description

I will be happy to provide any relevant info that may be required. Thanks in advance!

edit retag flag offensive close merge delete


rosbag will drop messages if the disk is not fast enough for all of the data. It's surprising that your image data decodes at all with those errors; is it possible the error is actually in the camera driver? Do you see the same issue if you view the camera image live while recording?

ahendrix gravatar image ahendrix  ( 2016-08-02 15:16:04 -0600 )edit

it's very unlikely that the error is in the camera drivers as I'm using widely used pointgrey camera drivers without any modification. Yes, I see the issue in the Rviz window while the bagfile is recording. However, I'm yet to see this issue when the bagfile is not being recorded.

gautam2410 gravatar image gautam2410  ( 2016-08-02 15:39:10 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-08-02 16:33:04 -0600

ahendrix gravatar image

First: widely used is not an argument for or against bugs. rosbag, rviz and the pointgrey drivers are all "widely used" and we need to be logical and methodical in our debugging. Intuition and reputation can guide the debugging process, but ultimately you have to follow the facts and the data.

If rviz shows corrupt data while recording and the data in the recorded bag file is the same, that points to a common failure somewhere upstream.

I see a couple of possibilities:

  • bug in the pointgrey driver itself
  • bug in the pointgrey library
  • subtle incompatibility between your camera and the pointgrey library
  • bug or dropped packets in the linux USB stack (possibly interacting with other active USB devices)
  • hardware bug on your camera

As a start, I would examine the images in the pointgrey camera viewer, while you record the rest of your data (without running the pointgrey ROS driver). That will tell you if the bug is in the ROS driver or not, while providing similar traffic on the network and USB.

You can also easily rule out interference from other USB drivers by running the pointgrey viewer without your recording setup running.

edit flag offensive delete link more


Thank you for outlining the possibilities. I'll start with your suggestion to view the images separately and then cross-check each possibility. I'll update you once I'm done with that. Do you have any suggestion/possible explanation for the drop in Velodyne frames? Thanks!

gautam2410 gravatar image gautam2410  ( 2016-08-02 17:11:24 -0600 )edit

Question Tools

1 follower


Asked: 2016-08-02 14:43:32 -0600

Seen: 2,892 times

Last updated: Aug 02 '16