Ask Your Question
1

rqt_graph rqt_tf_tree issue | ros indigo

asked 2016-07-11 15:04:56 -0500

Randerson gravatar image

Hello all,

I am facing an issue with the packages rqt_graph and rqt_tf_tree. When I run the mentioned packages I get the following error:

PluginHandlerDirect._restore_settings() plugin "rqt_graph/RosGraph#0" raised an exception:
Traceback (most recent call last):
  File "/opt/ros/indigo/lib/python2.7/dist-packages/qt_gui/plugin_handler_direct.py", line 116, in _restore_settings
    self._plugin.restore_settings(plugin_settings_plugin, instance_settings_plugin)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 202, in restore_settings
    self._refresh_rosgraph()
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 226, in _refresh_rosgraph
    self._update_graph_view(self._generate_dotcode())
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 259, in _update_graph_view
    self._redraw_graph_view()
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 292, in _redraw_graph_view
    same_label_siblings=True)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/qt_dotgraph/dot_to_qt.py", line 254, in dotcode_to_qt_items
    graph.nodes_iter = graph.get_node_list
AttributeError: 'list' object has no attribute 'get_node_list'

Any clue on how can I fix this problem?

edit retag flag offensive close merge delete

Comments

Does this persist if you remove .config/ros.org/rqt_gui.ini (make a backup first)? It might be in a slightly different location, depending on your desktop environment.

gvdhoorn gravatar image gvdhoorn  ( 2016-07-12 01:23:11 -0500 )edit

Yes, the problem persists after the remotion of the mentioned file.

Randerson gravatar image Randerson  ( 2016-07-12 09:05:42 -0500 )edit

Must say I have no idea, have not run into this myself. Something like this seems similar. Do you have any name in your ROS tf tree that contains a character that pyDot might not like?

gvdhoorn gravatar image gvdhoorn  ( 2016-07-12 13:56:09 -0500 )edit

No. I am just running roscore and the command rqt_graph.

Randerson gravatar image Randerson  ( 2016-07-12 14:42:23 -0500 )edit

Got the same problem, ROS indigo on OSX. Originally I had the error NameError: global name 'dot_parser' is not defined , then I updated pydot and pyparsing from 1.0.2->1.2.2 and 2.1.4->2.1.5 and got your error.

alf gravatar image alf  ( 2016-08-01 09:18:33 -0500 )edit

The packages are updated!!! :(

Randerson gravatar image Randerson  ( 2016-08-01 11:57:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-08-02 05:23:50 -0500

alf gravatar image

So I found some versions that seems to work (ROS indigo, /rosversion: 1.11.20, OSX).

I downgraded pydot to version 1.0.29: pip install pydot==1.0.29, and now rqt_graph seems to work fine.

edit flag offensive delete link more

Comments

Could you report this at ros-visualization/rqt_common_plugins/issues? Thanks.

gvdhoorn gravatar image gvdhoorn  ( 2016-08-13 11:43:19 -0500 )edit
1

It was reported in https://github.com/ros-visualization/... and has already been fixed.

Dirk Thomas gravatar image Dirk Thomas  ( 2016-08-17 11:40:01 -0500 )edit

Yes, I reported it on github. Sorry for not linking that here.

alf gravatar image alf  ( 2016-08-17 12:24:14 -0500 )edit

Thanks! Downgrading pip worked for me. Was facing the same issue with ROS Indigo on Mac OS X El Capitan

dexter05 gravatar image dexter05  ( 2016-08-24 21:52:22 -0500 )edit

Downgrading works for Jade too. Thanks!

Petro_19 gravatar image Petro_19  ( 2016-09-28 13:42:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-07-11 15:04:56 -0500

Seen: 956 times

Last updated: Aug 02 '16