ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
3

rqt button not show icon

asked 2021-02-26 21:56:32 -0600

DanielR gravatar image

updated 2021-05-24 17:10:52 -0600

jayess gravatar image

When I tried to install ROS Noetic on Ubuntu 20.04, I have a little problem about dependencies. So I used sudo aptitude install ros-noetic-desktop-full and I downgrade some library (I forget which libraries I downgrade). When I tried to run rqt_graph, the buttons on the window don't show icon image. When I tried to rum rqt_console or rqt_logger_level, the buttons on the windows don't show icon image. (Sorry, I can't include images because need > 5 points).

I tried to uninstall by sudo apt-get remove ros-* and install ros-noetic again. But still doesn't change anything. What should I do about it?

edit retag flag offensive close merge delete

Comments

I have the same issue, with all of the rqt plugins (rqt_bag, rqt_plot...). Have you had any luck? I am still able to use the plugins by hovering my mouse over the buttons, so the hint shows what each button does.

natetoombs gravatar image natetoombs  ( 2021-03-20 15:21:28 -0600 )edit

I have the same issue, clean install ubuntu 20, ros2 foxy.

bberrevoets gravatar image bberrevoets  ( 2021-04-04 15:05:23 -0600 )edit

Any updates?

natetoombs gravatar image natetoombs  ( 2021-05-21 11:59:01 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2021-05-24 11:31:49 -0600

natetoombs gravatar image

I found something that works for me! First, I made sure that the tango icon theme was installed sudo apt install tango-icon-theme.

Then, I was searching through all of my installed apps for icon settings, and I found an app called Qt5 Settings. It has the option to set the icon theme, so I set it to tango and hit apply, and now the icons show up for all of the rqt plugins! I hope that works for you!

edit flag offensive delete link more

Comments

1

Thanks, that seems to work! I'm using the osrf/ros:foxy-desktop docker image and was able to fix this problem there by sudo apt install qt5ct, export QT_QPA_PLATFORMTHEME=qt5ct then choosing the tango theme in the qt5ct application.

If anyone knows how to set the icon theme in the docker container without qt5ct, please share!

ottojo gravatar image ottojo  ( 2021-05-25 05:22:10 -0600 )edit

When I open Qt5 I cannot select Tango. It shows up but if I click nothing happens. How did you select Tango in the "Icon Theme"?

fabbro gravatar image fabbro  ( 2022-02-22 05:20:18 -0600 )edit

Thank you friend. I successfully solved the problem that troubled me according to your method

Happy Carl gravatar image Happy Carl  ( 2022-12-06 00:44:10 -0600 )edit
0

answered 2022-05-16 06:18:29 -0600

updated 2022-05-18 04:21:22 -0600

I think problem is in PyQT. Try to create a "hicolor" symlink that points to the tango theme. It works for me (I run rqt in docker container). This advice from https://www.pythonfixing.com/2021/12/...

 ln -s /usr/share/icons/Tango ~/.icons/hicolor
edit flag offensive delete link more

Question Tools

4 followers

Stats

Asked: 2021-02-26 21:56:32 -0600

Seen: 685 times

Last updated: May 18 '22