Ask Your Question
0

Custom message header file not generated

asked 2016-07-04 11:13:47 -0500

renjith gravatar image

updated 2016-07-04 11:15:02 -0500

I am trying to send a custom message from a ros publisher to an arduino mega using rosserial.The package containing the the publisher and custom message builds fine.I tried to generate headers for the custom message by using the command rosrun rosserial_client make_library.py path_to_libraries message_package given in rosserial_client/tutorials but it failed to generate the required header file for arduino.Can someone help me? The custom message file contains just two int16 variables.

edit retag flag offensive close merge delete

Comments

1

Did you remember to delete the old roslib folder in the libraries folder before running make_library.py?

Icehawk101 gravatar imageIcehawk101 ( 2016-07-05 08:22:06 -0500 )edit

Yeah i tried that too but no result.

renjith gravatar imagerenjith ( 2016-07-05 11:39:50 -0500 )edit

Thanks Icehawk101.When i deleted the roslib and ran rosrun rosserial_arduino make_libraries.py ~/sketchbook/libraries ,the required header files were generated.

renjith gravatar imagerenjith ( 2016-07-06 02:16:19 -0500 )edit

Please accept his answer, so the topic is closed.

vmatos gravatar imagevmatos ( 2016-07-07 06:53:31 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-07-06 08:20:43 -0500

updated 2016-07-06 08:21:22 -0500

Always remember to delete the old roslib folder in the libraries folder before running make_libraries.py, otherwise the header files won't be generated for the Arduino

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-07-04 11:13:47 -0500

Seen: 631 times

Last updated: Jul 06 '16