Ask Your Question
0

Need to resolve rosserial rostopic echo chatter not published yet

asked 2014-12-28 22:25:33 -0600

RoboBill gravatar image

After uploading the Hello World sketch to my Arduino Uno per the rosserial tutorial, I'm getting this "rostopic echo chatter WARNING: topic [/chatter] does not appear to be published yet".

I'm a real beginner with ROS, so hopefully someone has a link to the solution.

Thanks in advance

RoboBill

edit retag flag offensive close merge delete

Comments

Did you run the serial_node?

tonybaltovski gravatar imagetonybaltovski ( 2014-12-28 23:38:15 -0600 )edit

Hi Tony,

I followed the instructions per the rosserial tutorial...

in a terminal I ran... 1) roscore 2) rosrun rosserial_python serial_node.py _port:=/dev/ttyUSB1 3) In a new terminal.... rostopic echo chatter... thats where it "burps"

RoboBill

RoboBill gravatar imageRoboBill ( 2014-12-29 00:21:32 -0600 )edit

Is your Arduino connected /dev/ttyUSB1?

tonybaltovski gravatar imagetonybaltovski ( 2014-12-29 03:31:03 -0600 )edit

Yes... I uploaded the sketch successfully with the Arduino IDE via USB1

RoboBill gravatar imageRoboBill ( 2014-12-29 09:11:50 -0600 )edit

Hi Tony,

I just remembered I changed the bootloader on this Uno a few months back. So when I upload a sketch to this Uno, I choose the board type as a Duemilanove w/ ATmega328.

Does this help?

RoboBill gravatar imageRoboBill ( 2014-12-29 11:41:55 -0600 )edit

What does the serial_node output? Does it connect?

tonybaltovski gravatar imagetonybaltovski ( 2014-12-29 13:38:34 -0600 )edit

Hi Tony,

I get the following:

WARNING: topic [/chatter] does not appear to be published yet

Thanks

RoboBill

RoboBill gravatar imageRoboBill ( 2014-12-30 13:54:50 -0600 )edit

I meant, what output do you get from the serial_node?

tonybaltovski gravatar imagetonybaltovski ( 2015-01-04 22:11:38 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-01-06 20:37:04 -0600

RoboBill gravatar image

I believe I've figured it out. The tutorial did not specify that each instruction was to be entered into a new terminal. Once I did that I got data hello world

Thanks Tony for your patients

RoboBill

edit flag offensive delete link more
0

answered 2015-01-05 11:52:47 -0600

updated 2015-01-05 12:49:41 -0600

gvdhoorn gravatar image

When you run rosrun rosserial_python serial_node.py _port:=/dev/ttyUSB1 you should get something like so:

$ rosrun rosserial_python serial_node.py _port:=/dev/ttyUSB1
[INFO] [WallTime: 1420480219.434646] ROS Serial Python Node
[INFO] [WallTime: 1420480219.437731] Connecting to /dev/ttyUSB1 at 57600 baud
/opt/ros/indigo/lib/python2.7/dist-packages/rosserial_python/SerialClient.py:336: SyntaxWarning: The publisher should be created with an explicit keyword argument 'queue_size'. Please see http://wiki.ros.org/rospy/Overview/Publishers%20and%20Subscribers for more information.
  self.pub_diagnostics = rospy.Publisher('/diagnostics', diagnostic_msgs.msg.DiagnosticArray)
[ERROR] [WallTime: 1420480219.439001] Error opening serial: could not open port /dev/ttyUSB1: [Errno 2] No such file or directory: '/dev/ttyUSB1'
edit flag offensive delete link more

Comments

Wow... I get nothing like that. Should I uninstall then re-install ROS or is there a fix I can run?

RoboBill gravatar imageRoboBill ( 2015-01-06 12:35:24 -0600 )edit

What do you get?

tonybaltovski gravatar imagetonybaltovski ( 2015-01-06 13:59:48 -0600 )edit

I get nothing... sorry... I type roscore...(with the correct response) then I type in your command and ... nothing... darn

RoboBill gravatar imageRoboBill ( 2015-01-06 17:08:04 -0600 )edit

Finally!... not sure why but I typed in your command in a new terminal and got a response...

RoboBill gravatar imageRoboBill ( 2015-01-06 17:13:03 -0600 )edit

THE SAME PROBLEM HERE IF PLEASE ANY ONE HELP WHEN I RUN ""rosrun rosserial_python serial_node.py _port:=/dev/ttyUSB1"" NO thing is done

sazuddin gravatar imagesazuddin ( 2015-06-19 23:17:53 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-28 22:24:38 -0600

Seen: 2,006 times

Last updated: Jan 06 '15