the cmd "roslaunch gazebo_ros empty_world.launch" failure

asked 2016-06-16 06:44:47 -0600

godishair gravatar image

updated 2016-07-23 18:19:46 -0600

130s gravatar image

Hi, when I run "roslaunch gazebo_ros empty_world.launch", the error "Can't open /usr/share/gazebo//setup.sh" occurs at both the 'gzclient' and 'gzserver' . It's a weird path "/usr/share/gazebo//setup.sh", right? btw, I can't find the folder 'gazebo' neither.

Pls help, thx!

just attach the terminal prints:

... logging to /home/simon/.ros/log/952c350e-33b2-11e6-88c5-000c29ac34bc/roslaunch-ubuntu-3623.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://ubuntu:41188/

SUMMARY
========

PARAMETERS
 * /rosdistro: jade
 * /rosversion: 1.11.16
 * /use_sim_time: True

NODES
  /
    gazebo (gazebo_ros/gzserver)
    gazebo_gui (gazebo_ros/gzclient)

auto-starting new master
process[master]: started with pid [3635]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 952c350e-33b2-11e6-88c5-000c29ac34bc
process[rosout-1]: started with pid [3648]
started core service [/rosout]
process[gazebo-2]: started with pid [3651]
process[gazebo_gui-3]: started with pid [3654]

***/opt/ros/jade/lib/gazebo_ros/gzclient: 17: Can't open /usr/share/gazebo//setup.sh
/opt/ros/jade/lib/gazebo_ros/gzserver: 22: Can't open /usr/share/gazebo//setup.sh***

[gazebo-2] process has died [pid 3651, exit code 2, cmd /opt/ros/jade/lib/gazebo_ros/gzserver -e ode worlds/empty.world __name:=gazebo __log:=/home/simon/.ros/log/952c350e-33b2-11e6-88c5-000c29ac34bc/gazebo-2.log].
log file: /home/simon/.ros/log/952c350e-33b2-11e6-88c5-000c29ac34bc/gazebo-2*.log
[gazebo_gui-3] process has died [pid 3654, exit code 2, cmd /opt/ros/jade/lib/gazebo_ros/gzclient __name:=gazebo_gui __log:=/home/simon/.ros/log/952c350e-33b2-11e6-88c5-000c29ac34bc/gazebo_gui-3.log].
log file: /home/simon/.ros/log/952c350e-33b2-11e6-88c5-000c29ac34bc/gazebo_gui-3*.log
edit retag flag offensive close merge delete

Comments

You need to have /usr/share/gazebo/ which contains the setup.sh file and a folder named cmake in which there is the gazebo-config.cmake file. Check if you have those files. According to me, there is a slash too many in the path specified at the line 22 of the gzserver server.

lfr gravatar imagelfr ( 2016-06-17 04:48:02 -0600 )edit

it's weird that i don't have the folder "/usr/share/gazebo", I thought it becuz I hadn't installed the gazebo, but when I run sudo "apt-get install ros-jade-gazebo-*" the terminal shows me that the gazebo was already installed with the latest version. I am so much confused now!

godishair gravatar imagegodishair ( 2016-06-17 06:12:46 -0600 )edit

It is effectively strange. If gazebo is properly installed, I don't understand why you have not this folder.

lfr gravatar imagelfr ( 2016-06-17 06:30:09 -0600 )edit

I think I should follow the guidance by gazebowiki. thanks very much.

godishair gravatar imagegodishair ( 2016-06-17 07:04:14 -0600 )edit

You're welcome. Yes, it is a good idea, good luck

lfr gravatar imagelfr ( 2016-06-20 01:49:37 -0600 )edit

I just installed jade and I have exactly the same problem; it seems like the installation of gazebo is partial.

mhallak gravatar imagemhallak ( 2016-06-20 23:52:55 -0600 )edit
1

You don't have to ask a question as an answer. You can let a comment or ask a new question but not use an answer to ask a question. Else, have you installed the full gazebo ?

lfr gravatar imagelfr ( 2016-06-21 01:51:43 -0600 )edit