Ask Your Question
0

fails gazebo to start from ROS (boost::exception_detail error)

asked 2014-05-24 06:07:01 -0500

Arn-O gravatar image

Hi.

I am working on ROS Indigo on Ubuntu 14.04 LTE Thrusty (OK, I know it is not yet released).

When I try to start Gazebo, it fails most of the time (1 time in 10, it works). I use the simple command:

$ roslaunch gazebo_ros empty_world.launch

Here are the messages:

$ roslaunch gazebo_ros empty_world.launch
... logging to /home/arnaud/.ros/log/251a3d96-e35b-11e3-9539-0016eae586be/roslaunch-hercules-11967.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://hercules:46195/

SUMMARY
========

PARAMETERS
 * /rosdistro: <...>
 * /rosversion: <...>
 * /use_sim_time: True

NODES
  /
    gazebo (gazebo_ros/gzserver)
    gazebo_gui (gazebo_ros/gzclient)

auto-starting new master
process[master]: started with pid [11979]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 251a3d96-e35b-11e3-9539-0016eae586be
process[rosout-1]: started with pid [11992]
started core service [/rosout]
process[gazebo-2]: started with pid [12016]
/opt/ros/indigo/lib/gazebo_ros/gzserver: 5: [: Linux: unexpected operator
process[gazebo_gui-3]: started with pid [12020]
/opt/ros/indigo/lib/gazebo_ros/gzclient: 5: [: Linux: unexpected operator
Gazebo multi-robot simulator, version 2.2.2
Copyright (C) 2012-2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Gazebo multi-robot simulator, version 2.2.2
Copyright (C) 2012-2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Msg Waiting for masterError [Connection.cc:787] Getting remote endpoint failed
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::system::system_error> >'
  what():  remote_endpoint: Transport endpoint is not connected
[ INFO] [1400946636.551182005]: Finished loading Gazebo ROS API Plugin.
Msg Waiting for master
[ INFO] [1400946636.557603492]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 192.168.1.211
Aborted (core dumped)
[gazebo_gui-3] process has died [pid 12020, exit code 134, cmd /opt/ros/indigo/lib/gazebo_ros/gzclient __name:=gazebo_gui __log:=/home/arnaud/.ros/log/251a3d96-e35b-11e3-9539-0016eae586be/gazebo_gui-3.log].
log file: /home/arnaud/.ros/log/251a3d96-e35b-11e3-9539-0016eae586be/gazebo_gui-3*.log
[ INFO] [1400946637.091142150, 0.022000000]: waitForService: Service [/gazebo/set_physics_properties] is now available.
[ INFO] [1400946637.167613885, 0.093000000]: Physics dynamic reconfigure ready.
^C[gazebo-2] killing on exit
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

This one fails either:

roscore & rosrun gazebo_ros gazebo

The only way I found to make it work is to start one by one, roscore, gzserver and gzclient.

Does it come from the unstable state of ROS Indigo? Any idea how to fix this?

Thanks.

edit retag flag offensive close merge delete

Comments

Any ideas are welcome. Do you think that it could come from my hardware? (LENOVO T400)

Arn-O gravatar imageArn-O ( 2014-05-26 09:18:27 -0500 )edit
Arn-O gravatar imageArn-O ( 2014-05-27 09:47:39 -0500 )edit

Finally posted an issue in GitHub: https://github.com/ros/ros_comm/issues/421

Arn-O gravatar imageArn-O ( 2014-05-28 22:05:15 -0500 )edit

I experience same issue, running ROS Hydro, Ubuntu 12.04. roscore & rosrun gazebo_ros gazebo does not work, produces the following error: terminate called after throwing an instance of 'std::bad_alloc' what(): std::bad_alloc Yet, I am able to start gazebo using roscore, gzserver, and gzclient.

Orso gravatar imageOrso ( 2014-09-11 03:36:38 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-10-16 17:30:56 -0500

tfoote gravatar image
edit flag offensive delete link more
0

answered 2017-08-04 13:09:17 -0500

amkros gravatar image

This approach has worked for me after multiple installs and uninstalls finally. If you are using VirtualBox for running ubuntu just disable 3D acceleration from settings for your version. This solved the problem gazebo along with rViz which were crashing (un)expectedly. Although it did make the system slow. You can't have both at once. Hope this helps!!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-24 06:07:01 -0500

Seen: 6,596 times

Last updated: Oct 16 '17