ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

Run loop error: Serial Port read failure: device reports readiness to read but returned no data (device disconnected or multiple access on port?)

asked 2021-11-15 22:29:13 -0600

luongh gravatar image

Hi everyone,

I have 2 devices that connect to the ROS Melodic running on Ubuntu 18.04 (Jetson Nano 4Gb) through serial ports (/dev/ttyACM0 baud: 57600; and /dev/ttyACM1 baud: 115200). All of the nodes worked perfectly and there are no problem with the serial connection (rosserial_python pkg -> serial_node.py) if I run each single node separately step by step from console. However, if I put all those nodes into a launch file, the error happened as bellows:

"Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino."

"Run loop error: Serial Port read failure: device reports readiness to read but returned no data (device disconnected or multiple access on port?)"

If I remove one node that connect to /dev/ttyACM1 (or dev/ttyACM0) from the launch file, the launch file worked without any error. So I think the problem is narrowed to multiple access on port. Does anyone know how to solve it?

Many thanks,

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-11-16 18:11:54 -0600

miura gravatar image

The node that accesses /dev/ttyACM0 and the node that accesses /dev/ttyACM1 may have been set up with the same name.

Isn't the name="node_name" part of the launch file the same name? If so, a different name may help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-11-15 22:28:51 -0600

Seen: 317 times

Last updated: Nov 16 '21