ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Did ros-kinetic-gazebo-ros-control package release?

asked 2016-06-01 12:38:34 -0500

DKWatson gravatar image

Hi, I am trying to control my robot in the gazebo. But after following the tutorial, I get warning

Controller Spawner couldn't find the expected controller_manager ROS interface.

which is very similar to this answer. After tracking back, I find that I did not have "" file in my system. So I guess it is because I did not install ros-kinetic-gazebo-ros-control as instructed in the gazebo website. But when I try to type

sudo apt-get install ros-kinetic-gazebo-ros-pkgs ros-kinetic-gazebo-ros-control

I get this message

Reading package lists... Done

Building dependency tree

Reading state information... Done

E: Unable to locate package ros-kinetic-gazebo-ros-control

The gazebo_ros_control package for kinectic doesn't exist. I think that is why I don't have "" file in my system. How could I install ros-kinetic-gazebo-ros-control? Or does anyone know where my initial bug is?

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-06-02 04:36:16 -0500

I also encountered this - as a workaround I cloned the source into my project until it's added (it should be already but you can see the last commit message for gazebo_ros_control was about deleting CATKIN_IGNORE, so I think it just missed some sort of "submission deadline" or something?).

In project src directory;

git clone -b kinetic-devel

That will clone all the packages (which doesn't really matter - and in fact may be more stable since all the packages would be of the same revision), but it adds to the build time and it's only temporary so I used git sparse checkout to have only the relevant package;

cd gazebo_ros_pkgs
git config core.sparsecheckout true
echo gazebo_ros_control/ >> .git/info/sparse-checkout
git checkout
rosdep install --from-paths . -i -y

Then just catkin_make like normal etc.

edit flag offensive delete link more


Thank you Infinita! But then then is installed in home/user/catkin_ws/devel/lib, instead of in opt/ros/kinetic/lib. And I concern that the gazebo plugin cannot find this file because it is not in the right position. Should we copy the file back to opt/ros/kinetic/lib

DKWatson gravatar image DKWatson  ( 2016-06-02 14:43:14 -0500 )edit

Or redirect the filename in the gazebo plugin?

DKWatson gravatar image DKWatson  ( 2016-06-02 14:43:42 -0500 )edit

It shouldn't be a problem as long as the package (rospack find gazebo_ros_control to check) is in your ROS path. After you build, source your project like normal (source devel/setup.bash) and run gazebo from the same environment (gazebo).

Infinita gravatar image Infinita  ( 2016-06-02 21:11:44 -0500 )edit

I see, Thank you very much, infinita.

DKWatson gravatar image DKWatson  ( 2016-06-04 23:12:35 -0500 )edit

Hi , after trying the commands, I got this message and did not find the gazebo_ros_control: ERROR: the following rosdeps failed to install apt: command [apt-get install -y ros-kinetic-hardware-interface] failed

But surprisingly, the direct install comand worked after i tried it again: sudo apt-get install ros-kinetic-gazebo-ros-control

kodplayer gravatar image kodplayer  ( 2020-04-21 07:37:20 -0500 )edit

Question Tools

1 follower


Asked: 2016-06-01 12:38:34 -0500

Seen: 3,422 times

Last updated: Jun 01 '16