ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

The move_base isn't subscribing to /robot1/map

asked 2016-05-18 11:01:37 -0500

Orhan gravatar image

updated 2016-05-19 09:22:33 -0500

Hello everyone,

I'm trying to add a namespace to my robot. Firstly, I added _${arg robot_name} after all frames. I can control my different robots with rqt_robot_steering via their own control topics, for example, with this /robot1/mobile_base_controller/cmd_vel on gazebo. But I think that isn't important information, whatever;

When I try to run amcl, /robot1/move_base doesn't subscribe to /robot1/map. I'm already remapping in move_base node:

    <param name="base_global_planner" type="string" value="navfn/NavfnROS" />
    <param name="base_local_planner" value="dwa_local_planner/DWAPlannerROS" />
    <rosparam file="$(find mrp2_navigation)/config/dwa_planner_params.yaml" command="load" />

    <remap from="odom" to="odom_$(arg robot_name)" />
    <remap from="cmd_vel" to="$(arg robot_name)/nav_vel" />
    <remap from="map" to="/$(arg robot_name)/map" /> 

And setting in map_server:

    <node name="map_server" pkg="map_server" type="map_server" 
          args="$(find mrp2_navigation)/maps/milvus_repo.yaml" output="screen">
        <param name="frame_id" value="/$(arg robot_name)/map" />

Also Here is rqt_graph output:

(for newcomers to this website: right click image and say "Open image in new tab" for readable resolution)

image description

What should I set? Or What can I do?

Thanks in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-06-09 05:06:00 -0500

Orhan gravatar image

I've removed remapping. And problem solved. Launching node in

<group ns="optimus_prime">

tag already remaps topics automatically.

edit flag offensive delete link more



I got same problem with you, but I didn't add remapping in launch file, and move_base still not subscribe /robotx/map or /map. Do you have any idea of that. Thank you so much.

Ga_phantom gravatar image Ga_phantom  ( 2019-10-16 04:14:24 -0500 )edit

run roswtf and look at which topics are listened instead of the wanted one. Or which topics are orphan

Orhan gravatar image Orhan  ( 2019-10-16 09:01:52 -0500 )edit

I solved the problem by change "/base_footprint" to "base_footprint" in local/global_costmap_params.yaml, Thks.

Ga_phantom gravatar image Ga_phantom  ( 2019-10-19 02:30:00 -0500 )edit

Question Tools

1 follower


Asked: 2016-05-18 11:01:37 -0500

Seen: 1,245 times

Last updated: Jun 09 '16