Ask Your Question
0

ROS Indigo Source Build Fail - Ubuntu 14.04

asked 2016-05-06 11:05:40 -0500

user12821821 gravatar image

updated 2016-05-06 11:09:01 -0500

Trying to install ROS Indigo from source on Ubuntu 14.04.

I followed the instructions listed here exactly with no issues until the build: http://wiki.ros.org/indigo/Installati...

When invoking the following command, ROS fails to compile:

 ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Debug

I looked at a few other topics for help, ( http://answers.ros.org/question/21909... ) however my dependencies are fine:

~/ros_catkin_ws$ rosdep install --from-paths src --ignore-src --rosdistro indigo -y
#All required rosdeps installed successfully

No rule to make target /usr/lib/libPocoFoundationd.so', needed by/home/astaauser/ros_catkin_ws/devel_isolated/class_loader/lib/libclass_loader.so'. Stop.

I also tried to install libpoco from apt-get but no change in result since it was already installed fine.

~/ros_catkin_ws$ sudo apt-get install libpoco-dev

Reading package lists... Done Building dependency tree
Reading state information... Done libpoco-dev is already the newest version. The following packages were automatically installed and are no longer required: gnome-power-manager libjpeg-progs libjpeg-turbo-progs Use 'apt-get autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 542 not upgraded.

edit retag flag offensive close merge delete

Comments

Were you able to solve this issue?

Miguel Velez gravatar imageMiguel Velez ( 2016-11-18 12:46:47 -0500 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2017-10-27 17:12:24 -0500

cyberguy42 gravatar image

I ran into the same problem both when compiling indigo on 14.04 and kinetic on 16.04 . When you specify the 'Debug' build type, it needs to link against the debug version of the library. Running ls -al /usr/lib/libPocoFoundation* revealed that the symlink for libPocoFoundationd.so was broken: the library did not actually exist. Running sudo apt-get install libpocofoundation{version}-dbg resolved the problem both times, where {version} is whatever version is available to install.

edit flag offensive delete link more
0

answered 2017-04-13 12:18:49 -0500

dk1840 gravatar image

I ran into the same issue. I solved it by using sudo apt-get remove on all installed libpoco packages, installing libpoco from source and adding -DCMAKE_INCLUDE_PATH with the path for the newly-installed libpoco libraries to the catkin_make_isolated command.

edit flag offensive delete link more
0

answered 2016-05-06 11:31:56 -0500

jncjaen gravatar image

I think you can solve if you use ln.

locate libPocoFoundationd.so

this is a list when you have installed this program. When you have this, ln in the direction where you need it

sudo ln "direction in your list" "direction when you need"

Example: If when you installed, it have the name libPocoFoundationd.so.x.x

sudo ln /usr/lib/libPocoFoundationd.so.x.x /usr/lib/libPocoFoundationd.so

edit flag offensive delete link more

Comments

SThanks so much for your help, but I think the appropriate links are already setup, I did an ls -all where the library was located and got:

/usr/lib/libPocoFoundationd.so -> libPocoFoundationd.so.9
/usr/lib/libPocoFoundation.so -> libPocoFoundation.so.9

Still get the same error.

user12821821 gravatar imageuser12821821 ( 2016-05-06 12:25:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-05-06 11:05:40 -0500

Seen: 478 times

Last updated: Oct 27 '17