Ask Your Question
0

rosrun cannot find executables under turtlesim

asked 2016-04-25 20:41:13 -0500

GarethZhang gravatar image

updated 2016-04-25 20:41:48 -0500

I know this question has been asked many times, but I really wanted to understand what was wrong with my commands and environment setup. I tried solutions from other sources but none worked in my case.

I installed ROS indigo on Raspberry Pi 3 following this tutorial http://wiki.ros.org/ROSberryPi/Instal...

And I am going through beginner tutorials, currently on section "Understanding ROS Nodes" with following link: http://wiki.ros.org/ROS/Tutorials/Und...

As I ran command rosrun turtlesim turtlesim_node, the terminal gave following output error: [rosrun] Couldn't find executable named turtlesim_node below /home/pi/ros_catkin_ws/src/ros_tutorials/turtlesim

I have added source /opt/ros/indigo/setup.bash; source ~/ros_catkin_ws/devel/setup.bash;in the end of ~/.bashrc file.

Also, my working space is ros_catkin_ws.

As I run rospack profile, it produces following output:

0.065189 /home/pi/ros_catkin_ws/src

0.029168 * /opt/ros/indigo/share

0.020896 /home/pi/ros_catkin_ws/src/ros_comm

0.008227 /home/pi/ros_catkin_ws/src/ros_control

0.005578 /home/pi/ros_catkin_ws/src/ros

0.003114 /home/pi/ros_catkin_ws/src/roscpp_core

0.002664 /home/pi/ros_catkin_ws/src/joystick_drivers

0.002548 /home/pi/ros_catkin_ws/src/common_msgs

0.002168 /home/pi/ros_catkin_ws/src/ros_tutorials

0.001130 /home/pi/ros_catkin_ws/src/diagnostics

0.000709 /home/pi/ros_catkin_ws/src/ros_comm_msgs

As I run rospack find turtlesim, it successfully find location of the package at /home/pi/ros_catkin_ws/src/ros_tutorials/turtlesim

So can someone give me detailed instructions on how to follow the tutorial and find the executables? Thank you so much.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-25 21:16:34 -0500

langqy gravatar image

The location of the turtlesim package is in the dir. opt/ros/indigo/share, you can search turtlesim_node in your catkin workspace to make sure where there is a executable or not.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-25 20:41:13 -0500

Seen: 874 times

Last updated: Apr 25 '16