Ask Your Question
0

rosrun turtlesim turtlesim_node command

asked 2020-07-14 18:46:43 -0500

agerami gravatar image

Hello,

I am trying to run the turtlesim_node but I keep getting this error: qt.qpa.xcb: could not connect to display qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found. This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

Aborted (core dumped)

I am running ROS on Ubuntu 20.04 on Windows 10. I have tried GitHub and ROS answers but cannot find a solution. This is the tutorial I am using: http://wiki.ros.org/ROS/Tutorials/Und...

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2020-07-14 19:19:54 -0500

agerami gravatar image

Ah just needed more time. For all others trying to run on a Windows Subsytem I used this link: https://stackoverflow.com/questions/5...

Install Xming here: https://sourceforge.net/projects/xming/

and then run export DISPLAY=:0

edit flag offensive delete link more
0

answered 2020-11-06 03:02:25 -0500

hello! i have the same issue but i would like to find out more about the solution you posted.

Did u have to install Xming and windows subsystem for linux for the error to resolve?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-07-14 18:46:43 -0500

Seen: 722 times

Last updated: Jul 14 '20