Ask Your Question
0

install pcl-conversions when pcl is already installed

asked 2016-04-24 02:09:36 -0500

Juni gravatar image

Nowadays I installed PCL from source code because of a bug in pre-built binaries.

And now I want to install two packages ros-indigo-pcl-ros and ros-indigo-pcl-conversions using apt-get command.

But it says pcl-1.7 will be installed again.

I think installing pcl-1.7 again is redundant because I've already installed it from source code.

Is there any way to let apt-get know pcl-1.7 is already installed and skip installing it?

The resulting message of sudo apt-get install ros-indigo-pcl-conversions is as follow.

The following extra packages will be installed: libpcl-1.7-all libpcl-1.7-all-dev libpcl-1.7-bin libpcl-1.7-doc libpcl-apps-1.7 libpcl-apps-1.7-dev libpcl-common-1.7 libpcl-common-1.7-dev
libpcl-features-1.7 libpcl-features-1.7-dev libpcl-filters-1.7
libpcl-filters-1.7-dev libpcl-geometry-1.7-dev libpcl-io-1.7 libpcl-io-1.7-dev libpcl-kdtree-1.7 libpcl-kdtree-1.7-dev
libpcl-keypoints-1.7 libpcl-keypoints-1.7-dev libpcl-octree-1.7
libpcl-octree-1.7-dev libpcl-outofcore-1.7 libpcl-outofcore-1.7-dev
libpcl-people-1.7 libpcl-people-1.7-dev libpcl-recognition-1.7
libpcl-recognition-1.7-dev libpcl-registration-1.7
libpcl-registration-1.7-dev libpcl-sample-consensus-1.7
libpcl-sample-consensus-1.7-dev libpcl-search-1.7 libpcl-search-1.7-dev
libpcl-segmentation-1.7 libpcl-segmentation-1.7-dev libpcl-surface-1.7
libpcl-surface-1.7-dev libpcl-tracking-1.7 libpcl-tracking-1.7-dev
libpcl-visualization-1.7 libpcl-visualization-1.7-dev The following NEW packages will be installed: libpcl-1.7-all libpcl-1.7-all-dev libpcl-1.7-bin libpcl-1.7-doc libpcl-apps-1.7 libpcl-apps-1.7-dev libpcl-common-1.7 libpcl-common-1.7-dev
libpcl-features-1.7 libpcl-features-1.7-dev libpcl-filters-1.7
libpcl-filters-1.7-dev libpcl-geometry-1.7-dev libpcl-io-1.7 libpcl-io-1.7-dev libpcl-kdtree-1.7 libpcl-kdtree-1.7-dev
libpcl-keypoints-1.7 libpcl-keypoints-1.7-dev libpcl-octree-1.7
libpcl-octree-1.7-dev libpcl-outofcore-1.7 libpcl-outofcore-1.7-dev
libpcl-people-1.7 libpcl-people-1.7-dev libpcl-recognition-1.7
libpcl-recognition-1.7-dev libpcl-registration-1.7
libpcl-registration-1.7-dev libpcl-sample-consensus-1.7
libpcl-sample-consensus-1.7-dev libpcl-search-1.7 libpcl-search-1.7-dev
libpcl-segmentation-1.7 libpcl-segmentation-1.7-dev libpcl-surface-1.7
libpcl-surface-1.7-dev libpcl-tracking-1.7 libpcl-tracking-1.7-dev
libpcl-visualization-1.7 libpcl-visualization-1.7-dev
ros-indigo-pcl-conversions

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-04-24 21:37:04 -0500

ahendrix gravatar image

The version of pcl_conversions that you can install through apt was compiled against the version of pcl that you can install through apt.

If you want to use pcl_conversions with a version of pcl that you've built from source, you should also build pcl_conversions from source.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-24 02:09:36 -0500

Seen: 2,329 times

Last updated: Apr 24 '16