Ask Your Question
0

Problem when using multiple moveit IKFast plugins

asked 2016-04-18 04:15:42 -0600

PizzaTime gravatar image

Hello I have a Robot with four arms and Im using the MoveIt package. for each arm i´ve created a ikfast solver and a different plugin/catkin package. However moveit seems to load only one solver for all of the arms. It also seems to be a common problem but i havent found any solutions. When using one plugin alone the demo.launch is working fine for one leg. so all solver are working correct.

arm_1:
  kinematics_solver: arm_1_kinematics/IKFastKinematicsPlugin
  kinematics_solver_attempts: 3
  kinematics_solver_search_resolution: 0.005
  kinematics_solver_timeout: 0.005
arm_2:
  kinematics_solver: arm_1_kinematics/IKFastKinematicsPlugin
  kinematics_solver_attempts: 3
  kinematics_solver_search_resolution: 0.005
  kinematics_solver_timeout: 0.005
arm_3:
  kinematics_solver: arm_1kinematics/IKFastKinematicsPlugin
  kinematics_solver_attempts: 3
  kinematics_solver_search_resolution: 0.005
  kinematics_solver_timeout: 0.005
arm_4:
  kinematics_solver: arm_1_kinematics/IKFastKinematicsPlugin
  kinematics_solver_attempts: 3
  kinematics_solver_search_resolution: 0.005
  kinematics_solver_timeout: 0.005
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2016-04-18 10:18:34 -0600

PizzaTime gravatar image

ok i got it you have to rename the ikfast class in order to do so change the type in your description file to e.g.

ikfast_kinematics_plugin::NewIKFastKinematicsPlugin

and then change in "ROBOT_GROUP_ikfast_moveit_plugin.cpp" all entries from IKFastKinematicsPlugin to NewIKFastKinematicsPlugin

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-04-18 04:15:42 -0600

Seen: 245 times

Last updated: Apr 18 '16