Ask Your Question
0

ERROR rosout: Calibrate arm failed: Robust controller failed

asked 2016-03-27 12:16:59 -0500

rdhn gravatar image

So I am trying to calibrate Baxter's arms to have an accurate control(get rid of the unnecessary drifts of joints). On visual inspection I see that after running the script all the joints do get calibrated but suddenly at a very specific position every time(I believe that is just after calibrating W2), the arms disables itself with above error. I know the arm isn't calibrated properly because when I hold the cuff off button (zero gravity mode) the arm pulls back itself (a sign of poorly calibrate arm). Same thing happens when I reboot Baxter and run the Tare example. Any suggestion what I should do?

Also does having a torque control over any position/ velocity control or torque control alone help in avoid the drifting of arm. The reason I ask this is I when I command the arm to move to a position (I use IKsolver) it tries to reach there but the motion is not precise. It drifts off from the actual position and recovers after a sec or two to the original position. Maybe with torque control I can have a more accurate movement. I might be wrong. Any help much appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-15 11:32:10 -0500

rdhn gravatar image

Minute leveling adjustment and running the calibration and tare example a couple of time worked for me.

edit flag offensive delete link more

Comments

Have you contacted Rethink about this? Seems like a question for their support department.

gvdhoorn gravatar imagegvdhoorn ( 2016-04-16 04:26:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-03-27 12:16:59 -0500

Seen: 146 times

Last updated: Apr 15 '16