MoveIt Baxter no motion plan found error

asked 2016-03-14 11:40:22 -0600

atoz gravatar image

updated 2016-03-20 03:37:03 -0600

Hi,

I'm using MoveIt to plan and execute motion on the Baxter robot arms for teleoperation purposes in indigo. I'm using the python interface and the MoveGroupCommander to specify positions. I've tried both the group.set_pose_target() and group.compute_cartesian_path methods but they give the same error of No motion plan found and Unable to sample any valid states for goal tree.

Initially I set the arm to an initial position, using manual joint positions and group.set_joint_value_target() works fine to move the arm to the position. But after this, any changes in pose using the above methods for some reason moves the arm to a fully outstretched position after which it no longer moves.

I know the pose is valid because I set it manually using Rviz. I'm only incrementing it by 0.01 for the next position yet it still fails. Other people have encountered this problem before but there, the arms were of a too low DOF apparently.

Any help would be appreciated

[UPDATE]

So the commands I'm executing after getting the Baxter sim, trajectory controller and moveit_config running are:

moveit_commander.roscpp_initialize(sys.argv)
robot = moveit_commander.RobotCommander()
scene = moveit_commander.PlanningSceneInterface()
group = moveit_commander.MoveGroupCommander('left_arm')
group.set_joint_value_target(starting_joint_angles)
group.go()

This part works fine and the robot will move to the target position. However, when I do the following:

ik_pose = group.get_current_pose().pose
ik_pose.position.x = ik_pose.position.x + 0.01
group.set_pose_target(ik_pose,end_effector_link='left_gripper_base')
group.go(ik_pose, wait=False)

The output I get is:

[ INFO] [1458462578.594587151, 243.431000000]: LBKPIECE1: Created 1 (1 start + 0 goal) states in 1 cells (1 start (1 on boundary) + 0 goal (0 on boundary))
[ INFO] [1458462578.594648361, 243.431000000]: No solution found after 5.002070 seconds
[ INFO] [1458462578.598803820, 243.434000000]: Unable to solve the planning problem
[ INFO] [1458462578.600001066, 243.435000000]: Combined planning and execution request received for MoveGroup action. Forwarding to planning and execution pipeline.
[ WARN] [1458462578.600372071, 243.435000000]: Execution of motions should always start at the robot's current state. Ignoring the state supplied as start state in the motion planning request
[ INFO] [1458462578.600439178, 243.435000000]: Planning attempt 1 of at most 1
[ INFO] [1458462578.607187904, 243.437000000]: LBKPIECE1: Starting planning with 1 states already in datastructure

Hopefully this helps clarify things

edit retag flag offensive close merge delete

Comments

No one has any ideas?

atoz gravatar imageatoz ( 2016-03-17 08:21:37 -0600 )edit

All the commands you ran, and the copy-paste of the output lines usually helps more than verbal description does ;)

130s gravatar image130s ( 2016-03-17 10:21:03 -0600 )edit

Did you try using a different planner?

Sidd gravatar imageSidd ( 2016-12-13 11:45:06 -0600 )edit