Clearpath Husky customized configuration not showing up

asked 2016-03-11 17:47:37 -0600

autonomy gravatar image

updated 2016-03-11 17:48:25 -0600

So I followed . I and ended up with this file husky_customization/husky_custom_description/urdf/custom_description.urdf.xacro:

<robot name="husky" xmlns:xacro="">

  <xacro:arg name="laser_enabled" default="$(optenv HUSKY_LMS1XX_ENABLED false)" />
  <xacro:arg name="ur5_enabled" default="$(optenv HUSKY_UR5_ENABLED false)" />
  <xacro:arg name="kinect_enabled" default="false" />

  <xacro:include filename="$(find husky_description)/urdf/husky.urdf.xacro" />
  <xacro:husky_robot />

  <!-- Insert customization below, sample provided: -->

  <link name="avt_pan_link">
        <mesh filename="package://husky_custom_description/meshes/Manta+G32C.dae" />
      <origin xyz="0 0 0.0" rpy="0 0 0" />
        <box size="0.32 0.25 0.14" rpy="0 0 0"/>

  <xacro:sensor_arch prefix="" parent="top_plate_link">
    <origin xyz="0 0 0.51" rpy="0 0 -3.14"/>

  <joint name="avt_pan_joint" type="continuous">
    <parent link="sensor_arch_mount_link" />
    <child link="avt_pan_link" />
    <axis xyz ="0 0 1"/>
    <origin xyz="0.05 0.0 0.0" rpy="0 0 1.57" />


The visualization works just fine if I run everything on my laptop via roslaunch husky_viz view_robot.launch. It DOES NOT work on the actual Husky. The arch and the camera do not show up. I see that base.launch calls description.launch which references the HUSKY_DESCRIPTION var. Strangely enough, this var is set correctly:


But when I call rosparam get /robot_description the returned URDF does not contain my custom description. There is no transform published for the arch/camera and the arch does not show up in rviz. What am I doing wrong?

edit retag flag offensive close merge delete


Is this on an actual Husky that has been configured with robot_upstart?

tonybaltovski gravatar image tonybaltovski  ( 2016-03-11 22:58:33 -0600 )edit

Yes, this is on the Husky. I've run rosrun husky_bringup install.

autonomy gravatar image autonomy  ( 2016-03-14 08:33:40 -0600 )edit

I assume you have a workspace with your customization? Does the file in /etc/ros/setup.bash source that work space?

tonybaltovski gravatar image tonybaltovski  ( 2016-03-14 13:00:27 -0600 )edit

Hi, yes, it does. If I roscd to husky_customization, it brings me into my workspace correctly. I am unclear on step 7 from this tutorial, I'm not really adding any new launch files but I'm wondering if I should be

autonomy gravatar image autonomy  ( 2016-03-15 12:07:33 -0600 )edit

Mind providing the output of that file? cat /etc/ros/setup.bach

tonybaltovski gravatar image tonybaltovski  ( 2016-03-15 12:43:46 -0600 )edit

Ahh, I just figured it out. There was another ROS workspace being sourced AFTER mine and that somehow screwed things up. I either need to copy husky_customization to the last workspace being sourced, get rid of the workspace without husky_customization, or change the order of workspaces!

autonomy gravatar image autonomy  ( 2016-03-16 12:47:06 -0600 )edit