Ask Your Question
0

image_view symbol lookup error

asked 2016-03-10 06:55:38 -0500

nvoltex gravatar image

updated 2016-03-10 15:08:08 -0500

Hi there,

Whenever I try to use image_view to visualize a topic published by usb_cam with the following command:

rosrun image_view image_view image:=/usb_cam/image_raw

I get this:

init done 
opengl support available 
[ INFO] [1457614339.953957839]: Using transport "compressed"
/opt/ros/indigo/lib/image_view/image_view: symbol lookup error: /opt/ros/indigo/lib/image_view/image_view: undefined symbol: _ZN9cv_bridge18cvtColorForDisplayERKN5boost10shared_ptrIKNS_7CvImageEEERKSsbdd

The same happens even with the "raw" transport:

init done 
opengl support available 
[ INFO] [1457614438.464431134]: Using transport "raw"
/opt/ros/indigo/lib/image_view/image_view: symbol lookup error: /opt/ros/indigo/lib/image_view/image_view: undefined symbol: _ZN9cv_bridge18cvtColorForDisplayERKN5boost10shared_ptrIKNS_7CvImageEEERKSsbdd

Am I doing something wrong? has anyone got similar errors?

Thanks in advance.

edit retag flag offensive close merge delete

Comments

Please provide more information. What commands do you run so that these errors occur?

BennyRe gravatar imageBennyRe ( 2016-03-10 09:31:49 -0500 )edit

You are right, I'm sorry I forgot to add the command. Thanks for warning me.

nvoltex gravatar imagenvoltex ( 2016-03-10 15:08:31 -0500 )edit

this seems to point to a problem with linking. Did you install 'image_view' from source or via 'apt-get'? Which OS/ROS-Distro? Maybe also check if this answer helps...

mgruhler gravatar imagemgruhler ( 2016-03-11 02:45:06 -0500 )edit

If you installed via apt-get, you might have to source setup.bash.

source /opt/ros/indigo/setup.bash
hafager gravatar imagehafager ( 2016-08-04 09:36:21 -0500 )edit

@nvoltex Have you solved this problem?I met the same recently,I tried the other methods suggested by others,but all didn't work.

huisen liu gravatar imagehuisen liu ( 2016-09-10 09:19:34 -0500 )edit

In addition to Ziwen Qin's suggestion, I needed to run sudo apt-get install ros-indigo-cv-bridge. Versions of cv-bridge lower than 1.11.13 appear to cause this problem.

grmarcil gravatar imagegrmarcil ( 2017-04-19 13:37:49 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-11-21 06:34:07 -0500

Ziwen Qin gravatar image

updated 2016-11-21 06:41:45 -0500

This appears to be a bug with ROS' apt-get image-view program (version 1.12.18): https://github.com/ros-perception/ima...

I'd recommend running $ sudo apt-get update $ sudo apt-get install ros-indigo-image-view

to pull down the latest fixed package.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-03-10 06:55:38 -0500

Seen: 726 times

Last updated: Mar 10 '16