Ask Your Question
0

[head_camera] does not match name /camera/image_raw

asked 2018-01-10 06:34:14 -0500

Jeroenvdk gravatar image

updated 2018-01-10 06:44:05 -0500

I have the following launch file to use visp_auto_track with 2 cam's

<launch>    
  <!-- Launch the tracking node  -->
  <node pkg="visp_auto_tracker" type="visp_auto_tracker" name="visp_auto_tracker" output="screen">
    <param name="model_path" value="$(find visp_auto_tracker)/models" />
    <param name="model_name" value="pattern" />
    <param name="debug_display" value="True" />
  </node>

<!-- camera transforms -->
    <node pkg="tf" type="static_transform_publisher" 
        name="left_cam_tf" args="0 0 1.0 -1.570796 0 -1.570796 /map /left_camera 100"/>
    <node pkg="tf" type="static_transform_publisher" 
        name="right_cam_tf" args="0.0 -0.25 1.0 -1.570796 0 -1.570796 /map /right_camera 100"/>

 <!-- left cam-->
  <!-- Launch the usb camera acquisition node -->
<group ns="left_cam">
  <node name="usb_cam_left" pkg="usb_cam" type="usb_cam_node"  output="screen">      
    <param name="image_width" value="640" />
    <param name="image_height" value="480" />
    <param name="video_device" value="/dev/video1" />      
    <param name="pixel_format" value="yuyv" />
    <param name="framerate" value="30" />
    <param name="camera_frame_id" value="left_camera" />
    <param name="camera_info_url" value="package://visp_auto_tracker/models/calibration_left.ini" type="string" />
  </node>
  <node pkg="visp_auto_tracker" type="visp_auto_tracker" name="visp_auto_tracker" output="screen">
    <param name="model_path" value="$(find visp_auto_tracker)/models" />
    <param name="model_name" value="pattern" />
    <param name="debug_display" value="True" />
    <remap from="/visp_auto_tracker/image_raw" to="/left_cam/usb_cam_left/image_raw"/>
        <param name="autosize" value="true" />
    <remap from="/visp_auto_tracker/camera_info" to="/left_cam/usb_cam_left/camera_info"/>
  </node>
 </group>


<!-- Right cam-->
  <!-- Launch the usb camera acquisition node -->
<group ns="right_cam">
  <node name="usb_cam_right" pkg="usb_cam" type="usb_cam_node"  output="screen">           
    <param name="image_width" value="640" />
    <param name="image_height" value="480" />
    <param name="video_device" value="/dev/video2" />      
    <param name="pixel_format" value="yuyv" />
    <param name="framerate" value="30" />
    <param name="camera_frame_id" value="right_camera" />
    <param name="camera_info_url" value="package://visp_auto_tracker/models/calibration_right.ini" type="string" />
  </node>
  <node pkg="visp_auto_tracker" type="visp_auto_tracker" name="visp_auto_tracker" output="screen">
    <param name="model_path" value="$(find visp_auto_tracker)/models" />
    <param name="model_name" value="pattern" />
    <param name="debug_display" value="True" />
    <remap from="/visp_auto_tracker/image_raw" to="/right_cam/usb_cam_right/image_raw"/>
        <param name="autosize" value="true" />
    <remap from="/visp_auto_tracker/camera_info" to="/right_cam/usb_cam_right/camera_info"/>
  </node>
</group>

<!-- Launch visualizer -->
    <node name="rviz_node" pkg="rviz" type="rviz" />

</launch>

However, when I run this, I get the warnings:

[ INFO] [1515587518.127209475]: camera calibration URL: package://visp_auto_tracker/models/calibration_right.ini
[ WARN] [1515587518.127562984]: [head_camera] does not match name /camera/image_raw in file /home/jeroen/catkin_ws/src/vision_visp/visp_auto_tracker/models/calibration_right.ini
[ INFO] [1515587518.127615190]: Starting 'head_camera' (/dev/video2) at 640x480 via mmap (yuyv) at 30 FPS
[ INFO] [1515587518.217836910]: camera calibration URL: package://visp_auto_tracker/models/calibration_left.ini
[ WARN] [1515587518.218137831]: [head_camera] does not match name /camera/image_raw in file /home/jeroen/catkin_ws/src/vision_visp/visp_auto_tracker/models/calibration_left.ini
[ INFO] [1515587518.218179513]: Starting 'head_camera' (/dev/video1) at 640x480 via mmap (yuyv) at 30 FPS
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-06-24 19:14:53 -0500

skyofyao@gmail.com gravatar image

Check your .ini camera calibration file.

If the format is like this, your camera name is in one of the brackets. In your case, it should be [camera/image_raw]. Change that to [head_camera] should solve the problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-01-10 06:34:14 -0500

Seen: 188 times

Last updated: Jun 24