Ask Your Question
0

usb_cam on ubuntu 11.10

asked 2012-02-23 17:29:00 -0500

Parisa gravatar image

updated 2012-02-24 03:37:11 -0500

joq gravatar image

I want to use usb_cam on ubuntu 11.10 and ROS electric. when I use rosmake usb_cam --rosdep-install, it says: Failed to find rosdep libswscale for package usb_cam on OS:ubuntu version:oneiric

while I check libswscale, libswscale-dev and libswscale2 were installed in my system. any ideas to solve this error?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2012-03-22 22:21:40 -0500

abrsefid gravatar image

you can use gscam pkg instead of usb_cam

edit flag offensive delete link more
0

answered 2012-03-22 19:00:37 -0500

Hi,

Hope you have tried to make it directly. It works despite giving this error.

I got the same error, while I was doing rosdep install usb_cam But when I directly make it using : rosmake usb_cam Although it gave WARNING : [ rosmake ] WARNING: Rosdep did not detect the following system dependencies as installed: libswscale-dev Consider using --rosdep-install option or rosdep install usb_cam all packages were built successfully.

Then I ran it using : rosrun usb_cam usb_cam_node and I was able to see the image (streaming image like a video) in rviz on topic /usb_cam/image_raw.

Hope that helps.

edit flag offensive delete link more
0

answered 2012-03-23 01:57:23 -0500

Cav gravatar image

Edit /opt/ros/electric/ros/rosdep.yaml and add:

libswscale:
  ubuntu: libswscale-dev

but it will work even without it (just ignore the error).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-23 17:29:00 -0500

Seen: 534 times

Last updated: Mar 23 '12