Ask Your Question
0

How can I make my local plan path in navigation stack longer?

asked 2016-02-24 08:16:45 -0500

Double X gravatar image

Hy,

I have a pretty large robot which I'm trying to navigate using ROS Navigation stack. It is about 1.2m long and 0.8m wide. The problem is, when moving, the robot trajectory is oscillating around calculated global path (in other words - robot is not moving straight). At first I thought that the problem could be in control loop frequency which couldn't reach higher than 4Hz but after solving that problem the robot was still acting basically the same. Here is the link to the question about control loop frequency

http://answers.ros.org/question/22713...

When looking in rviz the calculated local plan, I find it very short (practically less than 30cm), when comparing it with my robots dimensions. It is always a lot shorter than my robot's footprint. So I was thinking if I could make my local plan longer the robot wouldn't oscillate that much.

So the question is - How can I make my local plan path in navigation stack longer?

Thanks in advance

edit retag flag offensive close merge delete

Comments

hello, i meet the same problom, do you have solved this one?

jiecuiok gravatar imagejiecuiok ( 2016-07-03 02:17:13 -0500 )edit
1

Hi @jiecuiok, could you please not post answers when you're not answering the question? Please use comments for these kinds of interactions. Thanks.

gvdhoorn gravatar imagegvdhoorn ( 2016-07-03 04:34:08 -0500 )edit

what is the local planner you are using?

Procópio gravatar imageProcópio ( 2016-07-04 01:50:58 -0500 )edit

the default local planner.I have solved this problem with tunning the sim_time and pdis_scale and gdis_scale.

jiecuiok gravatar imagejiecuiok ( 2016-07-04 06:38:26 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-07-04 01:55:52 -0500

Procópio gravatar image

If you are using the default local planner of ROS, you can check the Forward Simulation Parameters (section 4.2.3) here.

Try to play with those parameters, specially the sim_time, which is only 1.0 s by default. But beware that these parameters will have a visible impact on your cpu resources.

edit flag offensive delete link more

Comments

Yes, I changed it with sim_time, although I have written my own node for local and global planing so I'm not using Navigation Stack any more. Thnx

Double X gravatar imageDouble X ( 2016-07-04 03:34:05 -0500 )edit

Hey, how is the performance using your own global and local planners? Even I am facing that problem. Depending on your answer I will try to solve this problem

kiran gravatar imagekiran ( 2016-09-25 18:53:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2016-02-24 08:16:45 -0500

Seen: 873 times

Last updated: Jul 04 '16