Hokuyo UTM-30LX at 40Hz parameters for hokuyo_node (skip = 0)?

asked 2016-02-12 11:25:21 -0500

dchang0 gravatar image

updated 2016-02-12 11:30:25 -0500

The hokuyo_node README indicates that this set of parameters is known to work:

Intensity mode off:

cluster: 1
skip: 1
intensity: false
min_ang: -2.2689
max_ang: 2.2689

HOWEVER, skip = 1 results in the UTM-30LX running at 20Hz, not at the 40Hz it is capable of.

If I set skip = 0 for 40Hz operation, what min_ang and max_ang have any of you found to be rock-solid reliable/stable and yet capture the most data without overwhelming the USB bandwidth?

cluster: 1
skip: 0
intensity: false
min_ang: ??????
max_ang: ??????

I have tried using the same min_angle and max_angle as before (+/-2.2689), but this occasionally overwhelms the Hokuyo.

Thanks in advance!

edit retag flag offensive close merge delete