Ask Your Question
0

3D SLAM without IMU possible?

asked 2016-01-19 13:09:39 -0500

ARCHANA gravatar image

updated 2016-01-20 03:28:05 -0500

mgruhler gravatar image

hi, I'm very new to ros and working on the same problem of building 3d map using lidar but i don't have imu. can you please tell me is it possible to build 3d map without imu? and for that what is the procedure.

I have pioneer 3at robot with ros jade version.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-01-20 03:25:47 -0500

Sebastian Kasperski gravatar image

updated 2016-01-21 02:52:43 -0500

This depends on your sensor setup. If it can provide 3D-pointclouds at a high enough rate, you can do 3D-SLAM by aligning the pointclouds with an ICP-Algorithm. You can also use the pioneer's wheel odometry to replace the IMU to some extend.

Edit: A good ICP-Variant is the GeneralizedIterativeClosestPoint from pcl-registration library.

To create a 3D-Map with a 2D-Sensor (like your Hokuyo), you have to mount the Scanner on a tilt-unit to periodically tilt it up and down. Then PCL can create a pointcloud out of all scans from one full sweep of the scanner.

edit flag offensive delete link more

Comments

Thanks for the reply. The sensor i am using is hokuyo UTM 30 LX. I converted 2d laser data to pointcloud data using pcl library. Now if i move hokuyo in upward direction manually with hands then also z=0 and in rviz i see only 2d scan not 3d scan. Can you plz suggest me what should i do next.

ARCHANA gravatar imageARCHANA ( 2016-01-20 08:39:20 -0500 )edit

And if the solution is ICP algorithm then from where i can study that? Thanks

ARCHANA gravatar imageARCHANA ( 2016-01-20 08:44:20 -0500 )edit

I tried the same using "https://github.com/ras-sight/hratc2016_entry_template/wiki/pointcloud_generator_node" this package but when i run launch file, it is asking for tilting action server. i dont know how to write action server for that so i tried "rostopic pub " to move ptu but it doesnot move.

ARCHANA gravatar imageARCHANA ( 2016-01-22 04:12:08 -0500 )edit

What kind of ptu with what kind of ros-driver do you use?

Sebastian Kasperski gravatar imageSebastian Kasperski ( 2016-01-22 04:55:11 -0500 )edit

I am using PTU-E46 with flir_ptu_ros drivers. I installed this package from git source.

ARCHANA gravatar imageARCHANA ( 2016-01-22 05:25:51 -0500 )edit

Hi, sorry to disturb you again. I installed loam_continuous package from git source. Also i download data sets provided i.e bagfile and that is running fine in rviz using command rosbag play. but when i connect hokuyo utm 30lx with my laptop and run that package then i am not able to see 3d pointcld

ARCHANA gravatar imageARCHANA ( 2016-01-27 02:17:10 -0500 )edit

Also there is no error. Can you please tell me what changes i have to make in that package so as to use it for hokuyo utm-30lx.

ARCHANA gravatar imageARCHANA ( 2016-01-27 02:18:23 -0500 )edit

ARCHANA I also installed loam but point cloud is displayed only with rviz not with loam. Can u guess a possible reason for that ? it will be of great help thank u

asd gravatar imageasd ( 2017-10-13 15:38:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-19 13:09:39 -0500

Seen: 789 times

Last updated: Jan 21 '16