Ask Your Question
0

Robot_upstart can't find path in my package

asked 2016-01-19 10:02:49 -0500

TomSon gravatar image

updated 2016-01-26 03:02:24 -0500

Hi everyone, I got a bug using robot_upstart. I tried the install script with differents packages located in my catkin workspace and I get this :

Unable to locate path launch/example_lucos.launch in package teleopRoboteq. Installation aborted.

Is my catkin workspace corrupted ?

Thanks

Edit 26/01/2015: I just test with a new ROS instalation. I use a compiled package with catkin_make, roboteq_driver. The launcher and the job were correctly installed. I tried with my robot description package and robot_upstart doesnt find it for an install. How do you install your robot description package with ROS and, more importantly, where ?

edit retag flag offensive close merge delete

Comments

Can you also provide the rosrun command you used?

Akif gravatar imageAkif ( 2016-01-19 12:23:40 -0500 )edit

Here it is (something like that):

rosrun robot_upstart install lucos/launch/lucos.launch --interface p1p1

I also try on a new install and I get the same error.

TomSon gravatar imageTomSon ( 2016-01-20 01:30:56 -0500 )edit

It seems that there is a conflict between this 2 lines on some of my installations (.bashrc):

source /opt/ros/indigo/setup.bash
source ~/catkin_ws/devel/setup.bash
TomSon gravatar imageTomSon ( 2016-01-20 03:31:20 -0500 )edit

I have problems in robot_upstart too, maybe to write a upstart job to start your roslaunch is better option.

crazymumu gravatar imagecrazymumu ( 2016-01-20 21:15:03 -0500 )edit

I have done the same installation (i'm using the two line script to install ROS) on another computer. I just got the source of "joystick driver" and made a launch that I used with robot_upstart and I didn't get any trouble.

TomSon gravatar imageTomSon ( 2016-01-21 04:26:12 -0500 )edit

@TomSon: please describe your workspace layout and contents for us. Also add how you build it and what files you source (including your .bashrc). Issues with your ROS_PACKAGE_PATH would seem to suggest there is something incorrect in your ws setup / interaction.

gvdhoorn gravatar imagegvdhoorn ( 2016-02-02 02:08:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-01-20 04:21:16 -0500

Akif gravatar image

updated 2016-01-20 08:11:39 -0500

Your two source lines are not a conflict. In fact, both lines are necessary.

There may be a package name error in your rosrun command. What is your package name for the launch file in question? Can you provide the output of rospack find your_package_name ?

edit flag offensive delete link more

Comments

When I use rospack find , I dont find my package (here lucos).

TomSon gravatar imageTomSon ( 2016-01-20 06:33:34 -0500 )edit

Then it means that you have a problem with your workspace sourcing. Can you post the output of echo $ROS_PACKAGE_PATH ?

Akif gravatar imageAkif ( 2016-01-20 06:51:10 -0500 )edit

Only the second source command is necessary. The first one should have been done before creating the catkin_ws initially. Perhaps that was not done correctly?

joq gravatar imagejoq ( 2016-01-20 07:05:34 -0500 )edit

@joq, it is not a must but wiki states: "This process allows you to install several ROS distributions (e.g. fuerte and groovy) on the same computer and switch between them."

Akif gravatar imageAkif ( 2016-01-20 07:33:03 -0500 )edit

@Akif: no, @joq is correct. You should never need to do what @TomSon is doing, provided you created your workspace correctly. The "switching" you refer to is not meant to be in-place switching, but rather allows you to source a different setup.bash in a new terminal. Not in the same.

gvdhoorn gravatar imagegvdhoorn ( 2016-01-20 07:54:11 -0500 )edit

Although I do not think the problem is related with that, I updated my answer with feedbacks from you and @joq. Sorry for that.

Akif gravatar imageAkif ( 2016-01-20 08:14:15 -0500 )edit

@gvdhoorn, so there is indeed an issue with my workspace freshly installed ?

TomSon gravatar imageTomSon ( 2016-01-21 04:30:48 -0500 )edit

Well it depends on how you set it up. In principle you only source the last workspace in a chain. In this case, I'd say that is your catkin_ws (which overlays /opt/ros/indigo/..). Sourcing more than one setup.bash is not recommended (if supported at all, without additional arguments).

gvdhoorn gravatar imagegvdhoorn ( 2016-01-21 04:47:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-01-19 10:02:49 -0500

Seen: 787 times

Last updated: Jan 26 '16