Ask Your Question
0

error running rosrun command

asked 2016-01-04 09:14:17 -0600

ankur_27 gravatar image

updated 2016-01-04 14:27:32 -0600

gvdhoorn gravatar image

I am running catkin on Mac OS X, and build a project given in tutorial, when i run catkin_make, it build successfully without giving error.

but when i run rosrun first_tutorial talker command it gives me following error

dyld: Library not loaded: librospack.dylib
  Referenced from: /Users/ankurkhandelwal/ros_catkin_ws/install_isolated/bin/rospack
  Reason: image not found
find: ftsopen: No such file or directory
[rosrun] Couldn't find executable named talker below 
find: ftsopen: No such file or directory
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-01-05 20:49:42 -0600

updated 2016-01-06 21:07:08 -0600

Have you tried running this?

rospack profile

This should crawl your workspace and update the list of available packages for rosrun

[UPDATE]

Looking better at your report, it looks like your are having problems with DYLD_LIBRARY_PATH. You can find the fix in this github comment: https://github.com/mikepurvis/ros-ins... . I'll copy-paste it here for reference:

quick-and-dirty fix for this (for anyone else having trouble) was to add

export DYLD_LIBRARY_PATH=$DYLD_LIBRARY_PATH:/opt/ros/indigo/lib

to the start of /opt/ros/indigo/bin/rosrun, which resolves the issue.

edit flag offensive delete link more

Comments

@martin...i have run rospack but still same error

ankur_27 gravatar imageankur_27 ( 2016-01-06 03:43:30 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-04 09:14:17 -0600

Seen: 911 times

Last updated: Jan 06 '16