Ask Your Question
0

Gazebo seg fault Ubuntu/Indigo 14.04.02 [closed]

asked 2016-01-03 15:05:56 -0500

ptreyesguy gravatar image

I am running in native mode on i386. I am working out of the instructions in "learning Robotics using Python" by Lentin Joseph. I ran sudo apt-get install ros-indigo-gazebo-ros-pkgs ros-indigo-gazebo-ros-control I got roscore to run and then: rostopic list which shows:

/clock /gazebo/link_states /gazebo/model_states /gazebo/parameter_descriptions /gazebo/set_model_state /rosout /rosout_agg

Then: rosrun gazebo_ros gazebo The GUI comes up for a few seconds and then crashes.

First it connects to the gazebo master. Messages: [INFO] [/gazebo/set_physics_properties] is now available [INFO] Physics dynamic reconfigure ready

Segmentation Fault (core dumped)

30: kill: invalid signal number or name: SIGINT

? Does anyone know the solution?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2017-04-20 13:58:42.874516

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-01-06 02:19:23 -0500

Chickenman gravatar image

Maybe you can try to install

sudo apt-get install ros-indigo-gazebo5-ros-pkgs 
sudo apt-get install ros-indigo-gazebo5-ros-control

It solved a lot of problems in my case.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2016-01-03 15:05:56 -0500

Seen: 510 times

Last updated: Jan 06 '16