Ask Your Question
0

cannot launch node of type : can't locate node in package ERROR: cannot launch node of type : can't locate node in package

asked 2016-01-02 05:41:08 -0500

naqi.nick gravatar image

updated 2016-01-02 05:49:54 -0500

gvdhoorn gravatar image

when i launch the launch file of the frontier_exploration package provided by ros.org i recieve the following error:

 cannot launch node of type [frontier_exploration/explore_client]: can't locate node [explore_client] in package [frontier_exploration]
ERROR: cannot launch node of type [frontier_exploration/explore_server]: can't locate node [explore_server] in package [frontier_exploration]

help! plz

edit retag flag offensive close merge delete

Comments

the nodes are there inside the package but i dont know why it is showing such behavior

naqi.nick gravatar image naqi.nick  ( 2016-01-02 05:41:58 -0500 )edit

Please update your question with how you installed ROS, which version, which tutorial you followed, how you installed the frontier_exploration package, how you setup your workspace, etc, etc. How do you expect us to help you without that information?

gvdhoorn gravatar image gvdhoorn  ( 2016-01-02 05:51:06 -0500 )edit

http://wiki.ros.org/frontier_exploration i took the package available on this web address. i am using ros jade. installed it step by step as explained on ROS.ORG

naqi.nick gravatar image naqi.nick  ( 2016-01-03 07:08:00 -0500 )edit

i dont know why cant it find the file explore_client it is right inside the src folder of the package

naqi.nick gravatar image naqi.nick  ( 2016-01-03 07:09:15 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-02-16 04:11:16 -0500

naqi.nick gravatar image

there was a problem with my ROS Jade i reinstalled it and i started working properly

edit flag offensive delete link more
0

answered 2016-01-03 07:26:00 -0500

gvdhoorn gravatar image

installed it step by step as explained on ROS.ORG

I'm going to assume you followed the normal, binary ROS Jade installation tutorial, and that you git clone-ed frontier_exploration into your catkin workspace.

i dont know why cant it find the file explore_client it is right inside the src folder of the oackage

Have you built your workspace, and then sourced the correct setup.bash?

edit flag offensive delete link more

Comments

yes i did so

naqi.nick gravatar image naqi.nick  ( 2016-01-03 07:42:15 -0500 )edit

i am having problem in diagnosing this problem. can u help

naqi.nick gravatar image naqi.nick  ( 2016-01-03 07:46:59 -0500 )edit

Please update your original question with the exact steps you took to create your workspace, "took the package", built your workspace and what you did when you tried to start the explore_client node.

gvdhoorn gravatar image gvdhoorn  ( 2016-01-04 07:09:16 -0500 )edit

i extracted the downloaded package copied it into the catkin_ws/src folder. went to the terminal and did the following things. 1.cd ~/catkin_ws/ 2.catkin_make 3.source devel/setup.sh 4.roslaunch frontier _exploration global_map.launch

and it gave me the error which i have mentioned earlier

naqi.nick gravatar image naqi.nick  ( 2016-01-11 10:58:25 -0500 )edit
1

Please make sure the explore_client binary is there in catkin_ws/devel/lib/frontier_exploration.

gvdhoorn gravatar image gvdhoorn  ( 2016-01-11 11:15:13 -0500 )edit

thanks for your help there was a problem with my ROS jade i reinstalled it and now it working fine thank you

naqi.nick gravatar image naqi.nick  ( 2016-02-16 04:10:28 -0500 )edit

Hi, gvdhoorn, i have encountered the same problem here, i have tried many methods but no use, could you help me? thank you very much

xuao gravatar image xuao  ( 2016-04-15 03:01:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-02 05:41:08 -0500

Seen: 2,261 times

Last updated: Feb 16 '16