Problem in Movebase

asked 2015-12-15 19:37:14 -0500

Shams gravatar image

Hello,

I am trying to run a P3AT robot in a simulated area with Gazebo. I use amcl for localization and move_base for moving the robot. Whenever, I send a goal to move_base, it does not apply create the proper cmd_vel message to let the robot move. It normally returns the error message of "Rotate recovery can't rotate in place because there is a potential collision. Cost: -1.00" Then it complains with "Aborting because a valid plan could not be found. Even after executing all recovery behaviors" If I run roswtf it says: "ERROR The following nodes should be connected but aren't: * /move_base_node->/move_base_node (/move_base_node/global_costmap/footprint) * /move_base_node->/move_base_node (/move_base_node/local_costmap/footprint)"

I have tried the same code with real robot, and it works just fine. I would be thankful if you help me to figure out what the problem is.

edit retag flag offensive close merge delete

Comments

Did you fix it?

solosito gravatar imagesolosito ( 2016-01-21 03:26:57 -0500 )edit