Ask Your Question
1

Compile failed when compiling ros_control

asked 2015-11-11 11:13:29 -0600

MarkG gravatar image

updated 2016-10-24 09:09:36 -0600

ngrennan gravatar image

I have had ROS (indigo) running on a BeagleBone Black (running debian), by compiling everything, following this link:

http://wiki.ros.org/indigo/Installati...

I then tried to compile in ros_control (following all the steps at the bottom of the page)

rosinstall_generator ros_comm ros_control --rosdistro indigo --deps --wet-only --exclude roslisp --tar > indigo-custom_ros.rosinstall

The compile failed when trying to compile joint_limit_interface:

==> Processing catkin package: 'joint_limits_interface'
==> Building with env: '/opt/ros/indigo/env.sh'
==> cmake /home/debian/ros_catkin_ws/src/ros_control/joint_limits_interface -DCATKIN_DEVEL_PREFIX=/home/debian/ros_catkin_ws/devel_isolated/joint_limits_interface -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo -DCMAKE_BUILD_TYPE=Release -G Unix Makefiles in '/home/debian/ros_catkin_ws/build_isolated/joint_limits_interface'
CMake Error at CMakeLists.txt:4 (find_package):
  By not providing "Findurdfdom.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "urdfdom", but
  CMake did not find one.

  Could not find a package configuration file provided by "urdfdom" with any
  of the following names:

    urdfdomConfig.cmake
    urdfdom-config.cmake

  Add the installation prefix of "urdfdom" to CMAKE_PREFIX_PATH or set
  "urdfdom_DIR" to a directory containing one of the above files.  If
  "urdfdom" provides a separate development package or SDK, be sure it has
  been installed.

Looking around, there seems to be some talk on this, but I am still confused on how to proceed with the build.

Anyone have any step by step instructions on how to proceed?

Thanks!

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2015-11-12 02:26:16 -0600

tfoote gravatar image

You need to install liburdfdom-dev it is a system dependency: http://packages.ubuntu.com/trusty/lib...

edit flag offensive delete link more
0

answered 2015-11-12 06:51:42 -0600

MarkG gravatar image

updated 2015-11-12 09:17:18 -0600

I appreciate everyones feedback. I should have re-read the original link on installing on Debian. I did do a rosdep check... but missed the part about urdfdom(I reran it to verify)... Since this is Debian Wheezy on a BeagleBone, I need to compile a lot of system files including urdfdom, along with all ROS packages... Sometimes my eyes get crossed :)

By following the compile instructions for liburdfdom, I was able to successfully compile the rs_control package.

Thanks!

edit flag offensive delete link more
0

answered 2015-11-12 05:07:02 -0600

gvdhoorn gravatar image

To add to the answer by @tfoote: you need to make sure you have installed all dependencies before trying to build packages from source.

In most cases a rosdep check --from-paths /path/to/your/workspace/src --ignore-src --rosdistro=$DISTRO should tell you whether anything is missing. You can then either install the missing dependencies by hand, or run rosdep install .. with the same arguments to have rosdep install everything for you.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-11 11:13:29 -0600

Seen: 466 times

Last updated: Nov 12 '15