Turtlebot 2 stops responding after a short delay

asked 2015-11-10 14:32:52 -0500

afsantos gravatar image

updated 2015-11-11 09:43:39 -0500

The Turtlebot in question (with a Kobuki base) is brand new. It works in random walker mode, walking by itself, with no laptop connected.

The Problem

We turn Kobuki's switch on, it lights up the led and plays a sound. We connect it to the laptop, and run roslaunch to bringup the minimal setup, as per the tutorials. Kobuki answers by playing a connected sound. We can operate it for a while (diagnostics GUI, teleop, rostopic...), but then it plays a disconnected sound (like the previous sound but in reverse) and stops responding. This can also happen even if we do not launch anything else. This happens at varying intervals, from as short as a few seconds, to as long as a couple minutes after launching.

There are no error messages reported in the minimal bringup. There are, however, a couple of warnings, stating that we should upgrade the firmware (from 1.1 to 1.2) in order to have access to the latest features.

The Environment

We tested with multiple (virtual) machines, all with the same result. Namely:

  • Windows host, Linux Mint 17 guest
  • Windows host, Linux Ubuntu 14 guest (the iso provided in the tutorials)
  • Mac host, Linux Ubuntu 14 guest (ROS installed manually)

What is the cause of this behaviour? How can we fix it? Is this due to the use of virtual machines? Is this due to the outdated firmware?

Update: We managed to try it with a regular Ubuntu laptop, and it worked fine. So the issue seems to be related to VirtualBox. I am interested in knowing if virtual machines are usable at all.

edit retag flag offensive close merge delete