Cannot connect to Crazyflie Nano 2.0 through ROS package

asked 2017-03-30 10:28:37 -0600

thanhvu94 gravatar image

updated 2017-03-30 10:41:55 -0600

I cloned ROS package from here https://github.com/whoenig/crazyflie_ros into Raspberry Pi 3 (Ubuntu Mate 16.04). When I tried to execute the command rosrun crazyflie_tools scan I got an error Could not find Crazyradio with given devId.

I have successfully connected to CrazyflieVM on VirtualBox (I run it on another Windows desktop), and it can recognize my CrazyRadio (I passed the usb dongle from Windows to CrazyflieVM so that it can be recognized). Besides, according to https://github.com/bitcraze/crazyflie-lib-python#setting-udev-permissions, I have followed the steps to enable udev permissions. However, the same problem still persists.

Can everyone check the situation I described above to see if I'm missing something?

Thank you.

P/S1: I create a file to write udev rules by using the command sudo nano. . Besides, I don't know if I do the restart of udev in the correct way or not. If you have any clue about this, please give me the reference.

P/S2: On the directory /etc/udev/rules.d , besides my 2 newly created rules 99-crazyflie.rules and 99-crazyradio.rules , there are 3 other rules (10-local-rpi.rules, 40-scratch.rules, 99-com.rules). Are these 3 rules the default rules when we install Ubuntu on Raspberry Pi?

edit retag flag offensive close merge delete