Ask Your Question
0

Navigation Problem

asked 2015-11-02 02:39:05 -0500

nightblue gravatar image

updated 2015-11-02 02:46:59 -0500

Hello ROSers,

I have a custom robot on which I successfully run ROS Indigo. I built a map using gmapping here: http://i67.tinypic.com/20r31nb.png Image and video hosting by TinyPic

Afterthat I used AMCL for localization and saw that it successfully localizes itself on this map. everything perfect up to here! However, when I tried to use ROS Navigation package I faced some critical errors ! The map below shows the navigation path:

http://tinypic.com/r/eugbvb/9

Image and video hosting by TinyPic

Upto WayPoint1 everything is good. But when I gave Waypoint2 (WP2) command on Rviz, the robot always makes some absurd movements as you can see above picture!

I use encoders in my custom robot's motors, so I have good velocity control mechanism for the robot. I think the problem is in navigation but can't decide in which part of navigation parameters I should concentrate. For many days I have been trying to change some navigation parameters to solve this problem costmap_local.yaml, costmap_global.yaml, costmap_common.yaml and move_base.yaml. No change! :(

Any idea or insight for the problem solution please? Regards & Thanks

edit retag flag offensive close merge delete

Comments

can you create a video of it?

Procópio gravatar image Procópio  ( 2015-11-02 03:15:30 -0500 )edit

Dont have the video but I cansay that when I gave WP2 as target,it draws a nav. path very near to obstacle in middle and it always tries to pass too near to obstacle and it cant achieve in first try: turns back, tries again,.. turn bck again, etc...It at least makes 5 or more trials to pass obstcle

nightblue gravatar image nightblue  ( 2015-11-02 05:01:24 -0500 )edit

Also sometimes it stucks after some 10 or more trials !

nightblue gravatar image nightblue  ( 2015-11-02 05:03:10 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-11-02 06:55:37 -0500

Procópio gravatar image

According to your comments, I would try to increase the inflation_radius in your costmap_common.yaml You can have more details on the costmap_2d page, specially in the Inflation Section

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-02 02:39:05 -0500

Seen: 118 times

Last updated: Nov 02 '15