Ask Your Question
0

Possible to shut off obstacle avoidance (husky)?

asked 2015-10-28 05:21:48 -0500

mattiasbäx gravatar image

Hello ROS-community,

I have a problem you might help me figure out. I am using a husky to pick up certain objects, let's say these objects are boxes. I have a breadcrumb following navigation node that communicates with move_base to maneuver the environment and approach the box. The problem is that if i want to approach the box the husky will treat the box as an obstacle, thus trying to avoid it. Is it possible to "shut off" the obstacle avoidance, pickup the box, and power it on? I was reading this thread:

http://answers.ros.org/question/12276...

And thinking there might be a parameter i could reconfigure during runtime. Another problem i have is that i want to be able to take the fastest path if in order to align the husky to the box properly. If i give a goal point to move_base that's behind the husky, i want it to go backwards. But at the same time if the goal point is in front of the husky, it should move forward. Is this a possible behavior using dynamic reconfigure?

Another think with dynamic reconfigure as the thread above: Is there a need to call some sort of update, in order for the new parameters to take place? I made a simple node like the thread above to reconfigure some move_base parameters but when i read them from the terminal they hadn't changed.

TLDR: 1) Is it possible to "shut off" and "power on" obstacle avoidance during runtime? 2) Is it possible to have a behaviour that takes fastest path possible, which goes backwards if needed, and switch to "normal" maneuvering behaviour during runtime? 3) Do I need to call some sort of update for my dynamically reconfigured parameters to take place?

Thanks in advance! Wbr Mattias

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-11-03 04:06:29 -0500

mattiasbäx gravatar image

I might have figured it out, posting my findings here if anyone browses this thread:

1) I set the obstacle layer of the laser scanner to "enabled: false". This allows me to approach objects without planner stopping me. 2) Setting the min_vel_x to max_vel_x but switching sign solved this. 3) No, the parameters are updated when dynamically reconfigured.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-28 05:21:48 -0500

Seen: 131 times

Last updated: Nov 03 '15